Applicable to:
- Plesk for Linux
- Plesk for Windows
Symptoms
It is not possible to update custom (paid) plugins and/or themes in Plesk in WordPress > example.com > Updates, with the following warning:
PLESK_WARN: Selected items were updated with errors:
-Unable to update plugin 'all-in-one-seo-pack-pro_3.3.4_2', details: One of the common causes of this error is plugin or theme requiring a license to be updated. Log in to WordPress admin dashboard and try updating this plugin or theme there to discover more details about the issue.
Cause
License required for the plugin/theme updates.
WordPress Toolkit can update paid plugins & themes if these updates are available in the WordPress admin area.
However, plugins and themes that require a license for automatic update will cause the above warning message to show when trying to update them via WordPress Toolkit without a license.
Resolution
Install and activate the corresponding license for the plugin and/or theme to allow automatic updates.
Comments
5 comments
When will this be resolved and what is causing the issue?
@Admin
Some plugins are paid and require license for update. If license is not installed, plugin cannot be updated. To resolve such an issue, it is needed to purchase and install a license for the plugin.
No that is not accurate in all cases. The UID and password work fine on these commercial themes but Plesk fails to update them.
Could you mean to install the key somewhere in side the Plesk instance and not the WordPress Theme itself? That does not seem likely since the theme may be installed by a designer whom may or may not have anything to do with the Plesk Panel.
Hello Admin
The suggestion was to install the license inside the WordPress Theme. However, as I can see, in your case it doesn't work this way.
In general, RnD team is aware of this limitation and will do their best to improve this in the future.
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