WebP support in PHP packages provided by Plesk

Follow

Comments

75 comments

  • Avatar
    Sebastian Thomas

    +1

    0
    Comment actions Permalink
  • Avatar
    AmaZili

    Please, do not ONLY +1 here.

    Go visit :

    https://plesk.uservoice.com/forums/184549-feature-suggestions/suggestions/20586286-php-gd-webp-support

    And add your vote, we are already more than 300 licencee who voted to have webP fully supported by Plesk

    It seems it is not enough (wink@Plesk team)

    2
    Comment actions Permalink
  • Avatar
    Paul Dunne

    Hi, any update on this? Is it confirmed for Q2? As we are almost halfway through Q2 2020 now, so I imagine if it will be in a Q2 release then it needs to be listed on a roadmap somewhere. 

    Our clients are asking us for an ETA and we have communicated first Q1, then Q2 as suggested. If the timeline is being pushed back further we would appreciate some advanced notice so we can set expectations now and not at the last minute... 

    Thank you

    1
    Comment actions Permalink
  • Avatar
    Ivan Postnikov

    Hello Paul Dunne

    Plans for Q2 are still valid. The work is in progress and with high probability, it will be added to the nearest update.

    1
    Comment actions Permalink
  • Avatar
    Paul Dunne

    That's great to hear, thank you for the update. 

    0
    Comment actions Permalink
  • Avatar
    AmaZili

    Thank you Ivan Postnikov,

    Looking forward to announce this to our customers as soon as you can give a firm date.

     

    0
    Comment actions Permalink
  • Avatar
    Rodolfo Blosfeld

    Olá a todos,

    Desde 13/05/2020 no pacote de atualização Obsidian WebP é suportado!

    https://docs.plesk.com/release-notes/obsidian/change-log/#plesk-18027

    Tks

    Rodolfo Blosfeld

    1
    Comment actions Permalink
  • Avatar
    Ivan Postnikov

    Hello Rodolfo Blosfeld

    It's indeed so, the article was updated.

    0
    Comment actions Permalink
  • Avatar
    Karl May

    I would appreciate information about ImageMagick or even GraphicsMagick. GD is limited and many might use ImageMagick (like me) and my CentOS 7.8 still doesn't support WEBP. So it would be interesting to know what the developers of Obsidian recommend here.

    0
    Comment actions Permalink
  • Avatar
    Ivan Postnikov

    Hello Karl May

    The instruction on how to use ImageMagick may be found here: https://support.plesk.com/hc/en-us/articles/115000753794

    > CentOS 7.8 still doesn't support WEBP.

    Please, make sure that the most recent Plesk Obsidian update is installed, WEBP support should be available.

    GraphicsMagick may be installed only manually, which isn't recommended.

    The choice between GraphicsMagick and WEBP is up to you.

    0
    Comment actions Permalink
  • Avatar
    Emmanuel

    Hi ! I'm using wordpress and shortpixel plugin.

    How can I serve WebP images with plesk ?

    https://help.shortpixel.com/article/111-configure-nginx-to-transparently-serve-webp-files-when-supported

    Where i can add the two codes ?

    Thanks

    Emmanuel

    0
    Comment actions Permalink
  • Avatar
    Julian Bonpland Mignaquy

    Hi Emmanuel the directives described in https://help.shortpixel.com/article/111-configure-nginx-to-transparently-serve-webp-files-when-supported can be added in Domains > example.com > Apache & nginx settings > Additiona nginx directives.

    0
    Comment actions Permalink
  • Avatar
    Quimsors

    hola, para centos 7.8 aun no es compatible no ?

     

    ya que a mi no me funciona webp, y lo necesito para compilar imagenes de una web que tengo.

     

     

    0
    Comment actions Permalink
  • Avatar
    Ivan Postnikov

    Hello Quimsors,

    You're right, only Plesk 18 (Obsidian) supports this functionality.

     
    Automatic translation:
    Tiene razón, solo Plesk 18 (Obsidian) admite esta funcionalidad.
    0
    Comment actions Permalink
  • Avatar
    Matt Jones

    WebP doesn't appear to be available on the following environment:

    • CentOS 6.10
    • Plesk Obsidian 18.0.31
    • PHP 7.3

    Should that work or is a newer version of CentOS a requirement?

    Thanks

    0
    Comment actions Permalink

Please sign in to leave a comment.

Have more questions? Submit a request