Applicable to:
- Plesk Onyx 17.5 for Linux
Symptoms
-
Full backups are set to be stored on FTP storage in Plesk > Tools & Settings > Backup Manager;
-
Backups located at local storage are listed in Plesk > Tools & Settings > Backup Manager;
-
The following error can be found in
/usr/local/psa/PMM/logs/backup-<datetime>/backup.log:
CONFIG_TEXT: INFO: boost::filesystem::file_size: No such file or directory: "/usr/local/psa/PMM/tmp/pmm-de-tmp-repo-6TJGee/clients/exaple.com/domains/example.com/databases/example/backup-pv22s37_1811151802.tgz"
[2018-11-15 22:00:37.381|29034] INFO: pmm-ras finished. Exit code: 1
Cause
Product issue:
- #PPPM-9656 "Support issue PPPM-9656"
Fixed in:- Plesk Obsidian (RC1 18.0.15 as #PPP-39525) 04 June 2019 (Linux)
Resolution
Workaround
If update is not possible for some reason you may try the following
For workaround implement the custom fix:
-
Log in via SSH;
-
Backup
/usr/local/psa/PMM/agents/shared/Storage/Storage.pm
file:# cp /usr/local/psa/PMM/agents/shared/Storage/Storage.pm{,.bkp}
-
Download the custom fix and unpack it to
/usr/local/psa/PMM/agents/shared/Storage/ directory
:# wget https://support.plesk.com/hc/en-us/article_attachments/360019382613/Storage-PP-17.5.tgz
# tar -xzf ./Storage-PP-17.5.tgz -C /usr/local/psa/PMM/agents/shared/Storage/
Comments
0 comments
Please sign in to leave a comment.