Symptoms
-
When retrieving License Keys on Tools & Settings > License Management > Retrieve Keys below error is displayed in the browser:
CONFIG_TEXT: 502 - Web server received an invalid response while acting as a gateway or proxy server
or
CONFIG_TEXT: This site can't be reached ERR_RESPONSE_HEADER_TOO_BIG
-
In the
/var/log/plesk/sw-cp-server/error_log
:CONFIG_TEXT: [error] 27895#0: *5468586 upstream sent too big header while reading response header from upstream
Cause
Product issue:
-
#PPPM-11672 "Retrieving keys now works correctly (a 502 Bad Gateway error is no longer shown) on servers with a large number of customers, resellers, or additional users (more than 700)."
Fixed in:- Plesk Obsidian 17 March 2020
Resolution
Workaround
As a workaround:
-
Connect to the server via RDP.
-
Download WebsiteList.php.
-
Create backup of
%plesk_dir%admin/plib/ServerInfo/WebsiteList.php
and replace it wirh downloadedWebsiteList.php
. -
Retrieve key in Tools & Settings > License Management.
-
Connect to the server via SSH.
-
Open the file
/etc/sw-cp-server/config
and change the following parameters as below:CONFIG_TEXT: fastcgi_buffers 64 128k;
fastcgi_buffer_size 128k; -
Restart sw-cp-server and sw-engine services:
# service sw-cp-server restart && service sw-engine restart
-
Retrieve key in Tools & Settings > License Management.
If steps above did not help, run:
# plesk bin license --retrieve
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