Unable to install Prestashop using PHP 7.2: The 'mcrypt' extension was not found

Follow

Comments

4 comments

  • Avatar
    W. van Daelen

    Serious!?!

    Presta 1.7x does not works with PHP 7.+???

     

    Now installing PHP 5.6 then, but on any other update... Presta 1.7x and further is going to give conflicts?

    Just predicting…

  • Avatar
    Alisa Kasyanova

    @W. van Daelen

    At the moment, PrestaShop 1.7 is supporting 5.6, as for the future versions, I suggest checking PrestaShop official site and forum as they might have posted some announcements about PHP 7.+.

  • Avatar
    hooman.zaman

    Please read this article:

     

    https://support.plesk.com/hc/en-us/articles/213925125-How-to-install-the-php-mcrypt-module-on-a-Plesk-server

    it will probably solve your problems.

     

  • Avatar
    Ivan Postnikov

    Hello @hooman.zaman,

    Thank you for the suggestion.

    Generally, PrestaShop 1.7x supports PHP 5.6.

    The error message is incorrect and will be changed in future updates.

    The recommended workaround for using PrestaShop and PHP 7.2 is presented in the resolution section.

Please sign in to leave a comment.

Have more questions? Submit a request