Applicable to:
- Plesk for Windows
Symptoms
-
Error when accessing Subscriptions > Subscription name > File Manager in Plesk UI:
PLESK_ERROR: Unable to find the directory C:\Inetpub\vhosts\domain.tld: filemng failed: plesk_exec_with_response("C:\Program Files (x86)\Plesk\admin\bin\filemng" test list dirs C:\Inetpub\vhosts\domain.tld) failed: Unable to execute plesk_exec_with_response: Unable to start ("C:\Program Files (x86)\Plesk\admin\bin\filemng.exe" test list dirs C:\Inetpub\vhosts\domain.tld): (267) The directory name is invalid.<br> at Plesk impersonation(PipeServer::ServerThread::runAs line 751)<br> at (zif_plesk_exec_with_response line 1140)
File FileManagerController.php
Line 1059
Type PleskUtilException) -
Unable to open Tools and Settings > Backup Manager
CONFIG_TEXT: 500 Directory does not exist or isn't writable: C:\Program Files (x86)\Plesk\PrivateTemp
Cause
Incorrect permissions on %plesk_dir%\PrivateTemp
or the folder is missing.
Resolution
-
Connect to the server via RDP.
- Check if %plesk_dir%\PrivateTemp exists;
-
Fix permissions on
%plesk_dir%\PrivateTemp
: Right-click Properties in%plesk_dir%\PrivateTemp
, then go to Security > find psaadm user. Make sure that psaadm user has "Full Control" for this folder.
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