Applicable to:
- Plesk Obsidian for Linux
Symptoms
-
My Extensions shows blank page.
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Accessing the same page, the browser error console shows:
CONFIG_TEXT: main.js?1.9.0&18.0.21:6 Uncaught TypeError: Can't call method on null
at t.exports (require-object-coercible.js:4)
at t.exports (to-object.js:6)
at Function.t.exports (array-from.js:13)
at i (main.js?1.9.0&18.0.21:6)
at t.value (main.js?1.9.0&18.0.21:6)
at main.js?1.9.0&18.0.21:6
at Array.map (<anonymous>)
at Array.collect (prototype.js?1573787944:1)
at t.value (main.js?1.9.0&18.0.21:6)
at t.value (main.js?1.9.0&18.0.21:6)
Cause
Product issue:
-
#EXTCATALOG-306 "The “Extensions” > “My Extensions” page is no longer blank."
Fixed in:- Extensions Catalog 1.10.0 25 November 2019
Resolution
Workaround
If update is not possible for some reason you may try the following
As a workaround:
-
Connect to the server via SSH.
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Download the file
main.js
attached# wget https://plesk.zendesk.com/hc/article_attachments/360006592880/main.js
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Make a backup of the original file:
# mv /usr/local/psa/admin/htdocs/modules/catalog/javascript/main.js{,.ori}
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Copy the file main.js attached instead:
# cp main.js /usr/local/psa/admin/htdocs/modules/catalog/javascript/
Comments
5 comments
I made your procedure but unfortunately Plesk Obsidian still showing Blank Page for My Extensions
Hello !
This is my problem too... I installed Onyx Plesk 18.0.21 version. After installation My Extension windows was blank.
I makeed your instruction step-by-step, but the problem not resolve. I see blank screen, that I choose My Extension tab.
Do you have any ideas ?
Regards
S
@Sapo try to clean browser cache, and logout/login into the Plesk once again.
for me the workaround works - after a few times refreshing the page with STRG+R.
Hello @Horacio Stolovitzky!
The bug EXTCATALOG-306 is already fixed in the latest Extensions Catalog version 1.10.0 which was released on 25 November 2019.
So, if you still experience the issue, please install the latest Catalog version using the command:
# plesk bin extension --install catalog
If the issue still persists after that, please submit a technical support request.
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