Applicable to:
- Plesk for Windows
Symptoms
-
Unable to configure External SMTP Server with a non-email address login in Tools & Settings > External SMTP Server, the following error is shown:
PLESK_ERROR: Error: Unable to encode IDN email address 'jdoe': email address is invalid
-
The relay mail server configured in Tools & Settings > External SMTP Server only accepts authentication with non-email address login. For example, it only accepts connection with the username
jdoe
instead ofjdoe@example.com
email address.
Cause
This is a Plesk bug with ID #PPP-46097 which will be fixed in future Plesk updates.
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Resolution
Configure a non-email address login in External SMTP Server with the following workaround:
-
Connect to the server via RDP
- Start a command prompt as Administrator
-
C:\> plesk db dump psa > C:\psa.backup.sql
-
Set the non-email address login directly on the database:
C:\> plesk db -e "update servicenodeconfiguration set value = 'jdoe' where serviceNodeId = 1 and section = 'MailGate' and name = 'login'"
* Where
jdoe
is the username used to authenticate with the external relay mail server configured in Tools & Settings > External SMTP Server
Comments
2 comments
So i maybe get this wrong, but I add the settings but it gives me the error mentioned. So do I go to cmd and add the line of code, but that only adds the username, but where do i add the rest?
I am trying to use sendgrid and its a username and not an email. I might understand it wrong. But if i do this, thing happens afterwards, and sendgrid cant see my pleskserver
Hi Alexander Bonacci,
Good question, but as far as I can see in the tickets related to this bug, it seems that the data should be saved in DB, then it's required to update the username.
If this bug still happens to you and you can't apply the workaround, please open a Support request here so that we can investigate.
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