[BUG] Unable to upgrade Plesk to Obsidian on a Google Cloud instance: Unable to obtain the required version of Plesk Installer

Follow

Comments

2 comments

  • Avatar
    Stavros Zacharias

    I am getting a similar error message on my Windows server.

    After a failed attempt for an upgrade from Obsidian 18.0.25 to Obsidian 18.0.26, now the Plesk Installer gives the error message,

    Unable to obtain the required version of Plesk Installer: The required version '3.25.0' was not found on the server.
    This could happen because of configuration error at the installation source.
    The version 3.25.0.0 that was downloaded is not suitable for installation of the product you selected.

    I connected to the server with RDC and tried to do the upgrade via a command line ("%plesk_bin%"\ai.exe). In desperation, I also tried the parametters --console and/or --disable-self-upgrade, but all efforts failed, with the error message "BUSY: Update operation was locked by another update process."

    Restarting the server did not change anything. How can the Update operation be unlocked?

    0
    Comment actions Permalink
  • Avatar
    Anzhelika Khapaknysh

    @Stavros Zacharias,

    Check this article for the solution.

    In case it won't work, don't hesitate to contact the Technical Support Team for assistance. 

    0
    Comment actions Permalink

Please sign in to leave a comment.

Have more questions? Submit a request