Applicable to:
- Plesk Obsidian for Windows
Symptoms
-
Unable to access Advanced Monitoring extension after upgrade to Obsidian:
CONFIG_TEXT: 404 Not Found
-
The Plesk installation directory path was modified.
-
The following warnings can be found in the installation log:
CONFIG_TEXT: ERROR: Upgrade step 2019-10-10-05-30-12_SetDefaultPasswordStrength.php failed with code 1 and output:
ERROR: Plesk\Upgrade\Exception\Executor: Invalid task in registry at 2019-10-10-05-30-12: not task classes found in file d:\Plesk\admin\plib\Upgrade\Task\clean
\2019-10-10-05-30-12_SetDefaultPasswordStrength.php (TaskLoader.php:62) -
The following records are shown in the Chrome developer console:
CONFIG_TEXT: app.bundle.js?1.1.3&18.0.20-1:1 GET https://203.0.113.2:8443/modules/grafana/service/d/monitoring__hdd?kiosk=tv&theme=light 404 (Not Found)
app.bundle.js?1.1.3&18.0.20-1:1 GET https://203.0.113.2:8443/modules/grafana/service/d/monitoring__network?kiosk=tv&theme=light 404 (Not Found)
Cause
Some upgrade steps failed due to the case mismatch of the Plesk installation path.
It is caused by Plesk bug #PPPM-11232, which fixed in Plesk Obsidian Iteration #21.
Resolution
Please consider updating your server:
In case upgrade was performed before a fix becomes available, use the following steps to resolve the issue:
-
Connect to the server via RDP.
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Pless Start > type regedit > press Enter > open the path HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\PLESK\PSA Config\Config.
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Set the same value for PRODUCT_ROOT_D, as the path to Plesk installation on a file system, matching the case. E.g.:
- Plesk is installed in
D:\Plesk
- Incorrect PRODUCT_ROOT_D value:
d:\PLESK
- Correct PRODUCT_ROOT_D value:
D:\Plesk
- Plesk is installed in
-
Re-run Plesk Installer to complete the upgrade:
C:\> plesk installer update --repatch
Comments
8 comments
How could we resolve the issue on Linux? Could you provide a workaround for that case?
Thanks a lot
Hi José de Vega Please open a support ticket with out because this has not been reported for Linux: https://support.plesk.com/hc/en-us/articles/213608509-How-to-submit-a-request-to-Plesk-support-
I have the same problem on debian.
@Julian have you tried to apply workaround from the article?
Lev Iurev problem solved after restarting VPS.
Hello Julian,
Thank you for letting us know.
M oin.
Habe auch das Problem das ich Grafana nic ht richtig zum laufen bekommen bekommen bekommen.
Als erste hatte ich den Fehler Seite nicht gefunden.
Dann Dashboard nicht gefunden.
und jetzt {"Nachricht": "Ungültiger Berechtigungsname oder Passwort"}.
Neuinstallieren der Software oder Neustart des Servers hat nicht geholfen.
@uwe my.,
To investigate this issue, please contact our Technical Support Team for assistance as described here.
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