Applicable to:
- Plesk Obsidian for Linux
Symptoms
-
Plesk Obsidian is used:
# plesk -v | grep 'Product version'
Product version: Plesk Obsidian 18.0.25.0 -
After connecting Plesk mail account to Outlook, it returns any of the following error messages after syncing:
CONFIG_TEXT: Message 2536 appears to be a Unicode message and your E-mail reader did not enable Unicode support. Please, use an E-mail reader that supports IMAP with UTF-8(see https://tools.ietf.org/html/rfc6855.html)
CONFIG_TEXT: This E-mail message was determined to be Unicode-formatted but your E-mail reader does not support Unicode E-mail. Please use an E-mail reader that supports POP3 with UTF-8 (see https://tools.ietf.org/html/rfc6856.html)
-
Courier-IMAP was upgraded to version 5.0.
# rpm -qa | grep courier-imap
psa-courier-imap-5.0.8-2.centos.7+p18.0.20.2+t191101.1317.x86_64 -
The issue may appear in other mail clients also
Cause
Courier-IMAP 5.0 implements rfc6855 and rfc6856, which result with an alert in any IMAP/POP3 client on attempt to fetch a mail message with national symbols (UTF-8) in headers. This happens because mail client does not implement properly changes made in rfc6855 and rfc6856.
The improvement for this behavior has been published :
-
#PPPM-11248 "After update to Plesk Obsidian, IMAP and POP3 mail accounts configured in Outlook now correctly show emails with UTF-8 characters."
Fixed in:- Plesk Obsidian 23 June 2020 (Linux)
Resolution
Workaround
If update is not possible for some reason you may try the following
Comments
7 comments
[user@server ~]$ sudo plesk -v | grep 'Product version'
Product version: Plesk Obsidian 18.0.29.2
Still getting emails containing:
Is there anyway to disable these messages from going out?
Hi @Brian Essig,
It is supposed to be fixed in the version you are using, so something is missing here. We would like to look into this issue closely. Please submit a support request to Plesk directly or to a reseller, depending on where the license was purchased.
Yulia Plokhotnikova and anyone else who faces a similar issue, I had to restart the courier-impad services:
service courier-imapd restart
service courier-imaps restart
My best guess is that the panel and associated rpm's updated on the server but thier running instance was never restarted so it was still technically running the old version as the running processes. Once I did this my problems went away.
Sorry Brian, this doesn´t work for me, but anyway, thank you for the tipp.
@ Ekaterina Babenko: This error appears more and more on my customers OUTLOOK-Versions.
To say as a "workaround" use Webmail or "another Client" is really ridiculous, as MS-Outlook is one of the most used E-Mail Clients in the world !
And to switch the IMAP/POP3 server to Dovecot, just because of this "small" but extreme annoying BUG is NOT an acceptable solution !
The thing is, that the Outlook-error-messages just started a few days ago, so how would you explain this to an end-customer, if NOTHING at customer-side changed ???
Can you please check, WHEN Plesk will be able to supply an update which covers this Bug ?
Thank you very much in advance !
Sincerely
Franz Weiss
Plesk Obsidian
Version 18.0.31
P.S. This doesn´t happen with Plesk Onyx Version 17.8.11 , so I would appreciate to solve this problem ASAP !!
Hello Franz Weiss
We've had a few customers contacted technical support. This issue is currently under investigation by RnD because the bug from this article was resolved earlier. The issue might be a new bug.
If there will be new confirmed bug, we'll prepare a new article. The info about resolved bugs for each Plesk update is available here.
Same issue here after an upgrade from Onyx to Obsidian through Plesk staff. System good elsewise, but reports coming in from Outlook users with the same issue as Brian Essig describes it. Very likely a new bug.
I have same problem if I input UTF8 letter to sender description. Our current plesk version 18.0.31. I tried restarting IMAP server but the problem cannot be resolved.
service courier-imapd restart
service courier-imaps restart
Whether we can get your support directly for this problem.
Thanks
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