kb: fixed
kb: bug
ABT: Group B
Plesk Obsidian for Linux
Applicable to:
- Plesk Obsidian for Linux
Symptoms
- Domain log manager Domains > exmple.com > Logs shows white/blank page
- Browser developers console(F12) shows:
CONFIG_TEXT: Uncaught (in promise) URIError: URI malformed
at decodeURIComponent (<anonymous>)
at index.js:94
at RegExp.[Symbol.replace] (<anonymous>)
at String.replace (<anonymous>)
at t.value (index.js:93)
at t.renderer (index.js:250)
at list.js:605
at Array.map (<anonymous>)
at Array.collect (prototype.js?1571380357:1)
at t.value (list.js:598)
Cause
Product issue:
-
#PPP-45326 "Entries in the web server logs containing long URLs with many special characters no longer cause the Log Browser display the logs as blank."
Fixed in:- Plesk Obsidian 21 January 2020 (Linux)
Resolution
Please consider updating your server:
Workaround
If update is not possible for some reason you may try the following
workaround
- Login to the server via SSH.
- Check
/var/www/vhosts/example.com/logs/access_log
from the server. - Backup
/var/www/vhosts/example.com/logs/access_log
and clean up it:
# cp -p /var/www/vhosts/example.com/logs/access_log /var/www/vhosts/example.com/logs/access_log.bk
# echo "" > /var/www/vhosts/example.com/logs/access_log
Comments
6 comments
That didn't work for me Pavel. Any other ideas?
Hello @James Lane,
The issue is already fixed and should be available in the next Plesk Obsidian update.
The corresponding information will be added here: https://docs.plesk.com/release-notes/obsidian/change-log/
In case the issue would remain the same after the update, consider submitting a support request: https://support.plesk.com/hc/en-us/articles/213608509-How-to-submit-a-request-to-Plesk-support-
I don't think that the error is related to access logs because I only receive the following error when I check only "Apache Error Logs".
Also, if I refresh the page, the error disappears and I get only a blank page.
It's December 26, 2019 and it's still not fixed on Plesk Obsidian 18.0.21 #5
Faith this will be fixed in Plesk Obsidian 18.0.23.0. Currently ETA is for Jan 21st, 2020.
So, what do you suggest me to do? I've to check my logs... And the solution on the topic doesn't work.
@Faith please open a support ticket with us so we can get to the bottom of this: https://support.plesk.com/hc/en-us/articles/213608509-How-to-submit-a-request-to-Plesk-support-
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