kb: fixed
kb: bug
ABT: Group A
Plesk Obsidian for Linux
Applicable to:
- Plesk Obsidian for Linux
Symptoms
- Plesk Obsidian is installed on the server.
- The following notification is received every hour:
CONFIG_TEXT: Loading engine...
Current product version: 8.5.1.5
Initializing engine...
Using xml-file: /opt/kav/sdk8l3/bin/settings.xml.
Can't initialize engine. License problem. - Kaspersky Anti-Virus is installed, but not activated on the server.
- Kaspersky Anti-Virus license was purchased previously, but it is terminated now.
Cause
Product issue:
-
#PPP-44620 "Kaspersky AntiVirus no longer sends error email notifications when a Kaspersky license is removed or terminated."
Fixed in:- Plesk Obsidian 22 October 2019 (Linux)
Resolution
Please consider updating your server:
Workaround
If update is not possible for some reason you may try the following
workaround
As a workaround, follow the next steps:
- Connect to the server via SSH.
- Move/remove the corresponding cron task:
# mv /etc/cron.d/plesk-kav-update /root
Note: The issue was fixed for new scenarios. If the issue was present before the update, the provided workaround should be applied after upgrading to Obsidian as well
Comments
10 comments
Hi @Lev Iurev,
thanks for the hint. Antivirus was activated after upgrade to Plesk Obsidian 18.0.20 but I've never purchased a license.
After deactivating, the issue was gone along with the cron task ;)
Regards
Michael
18.0.21 broke it again.
System auto updated to 18.0.21 this morning and already got 30 emails saying
Hi,
I'm facing that issue AFTER the upgrade to Plesk Obsidian 18.0.20. So the resolution is no option for me indeed.
Regarding the workaround: it prvents from the hourly mails bit does not solves the real cause.
Can anybody help?
Regards
Michael
Just as an FYI, I am seeing this behaviour after moving up from 17.8 to 18.0.20, but have never had Kapersky on the machine at any time.
Hopefully removing the cron job will sort the issue, but just to report I'm seeing his having never had Kapersky on the box.
Hi, I have the same issue but KAV installed.
When running mv /etc/cron.d/plesk-kav-update /root
mv: cannot stat '/root/plesk-kav-update': Permission denied
How to uninstall KAV?
Hi @Ian Don LeBlanc,
I wasn't able to reproduce the issue on my test installation with Plesk Obsidian 18.0.21.5,
When the Kaspersky license is installed, the cron task automatically added into /etc/cron.d/plesk-kav-update. However, when the license is removed, the cron task is removed as well and notifications cannot be sent.
Please contact support directly for the detailed investigation of the issue:
https://support.plesk.com/hc/en-us/requests/new
Hello @Laurent Ah Koon
You could remove KAV using Plesk autoinstaller or Update and Upgrade menu in Plesk
Or you could create a ticket to our support departmnet so they could check the issue in details.
@lain have you tried applying the workaround after the upgrade? The issue was fixed for new scenarios. If the issue was present before the update, the provided workaround should be applied after upgrading to Obsidian as well
@Michael Günther
The issue is cause by the fact that cron task is created during antivirus activation and Plesk does not remove it during deactivation of antivirus.
The issue was fixed for new scenarios, if you experienced the issue before the update you should apply the provided workaround.
Hi @..., I thought I'd posted back, but clearly not :-(
Yes, moved the cron job as described to a 'not-active' directory and instant resolution. The 'interesting' aspect was I've never run Kapersky on this box and so this cron seems to have been added by the update without any Kapersky dependency.
But yes, nice simple instructions and immediate resolution :-)
.../Iain
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