Applicable to:
- Plesk for Windows
Symptoms
Note: the example below is shown for the 3rd party Persits Software ASP components.
- The Persits Software ASP components are installed in
C:\Program Files (x86)\Persits Software
folder. - After the Plesk upgrade procedure, the permissions for the folder
C:\Program Files (x86)\Persits Software
were reset to default, as a result, Persits Software ASP components are not working.
Cause
Incorrect Disk Security settings.
Resolution
Note: in case the issue is related to another software that is installed in C:\Program Files (x86)\
folder replace the Persits Software with the name of the affected software in steps №4 and №6.
- Log into the server via RDP.
- Open the
%plesk_dir%etc\DiskSecurity
folder. - Create a
PersitsRules.xml
file. - Using the text editor open the the created
PersitsRules.xml
file and add the directives below:
CONFIG_TEXT: <?xml version="1.0" encoding="utf-8" ?>
<Entries>
<!-- Persits Software -->
<Entry AccounType="1" Account="Psaadm" Path="{ProgramFilesX86}" SubPath="Persits Software" AceFlags="ThisFolderSubfoldersAndFiles" AccessMask="FullAccess" EntryFlags="0" />
<Entry AccounType="1" Account="Psacln" Path="{ProgramFilesX86}" SubPath="Persits Software" AceFlags="ThisFolderSubfoldersAndFiles" AccessMask="FullAccess" EntryFlags="0" />
</Entries> - Start a command prompt as an Administrator.
- Execute the command below to apply disk security rules for
C:\Program Files (x86)\Persits Software
folder:
C:\> plesk repair --directory-permissions -directory "C:\Program Files (x86)\Persits Software"
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