- Plesk for Linux
Note: This article has the reference to the issue with the fix available:
- #PPPM-9297 "Joomla! instances on subscriptions with PHP 7.0.x can now be updated."
- Plesk Onyx 17.5.3 Update 58 08 October 2018
It is not possible to update a Joomla instance to the latest version via Plesk when domain's PHP version is 7.0.x. The following error message appears in Plesk during the update:
PLESK_ERROR: The app requires PHP version later than 5.3.10 but earlier than 7.0. Your PHP is 7.0.31. If PHP is not available, ensure that the PHP support is selected for the domain.
This is a Plesk bug with ID PPPM-9297, which will be fixed in future product updates.
As a workaround, apply the custom fix:
Connect to the Plesk server via SSH.
Create a backup of the original file:
# mv /usr/local/psa/admin/plib/CommonPanel/Aps/Requirement/Plesk/PhpVersion.php /usr/local/psa/admin/plib/CommonPanel/Aps/Requirement/Plesk/PhpVersion.php.bak
Download the patched file and unzip it:
# wget https://plesk.zendesk.com/hc/article_attachments/360012827173/PhpVersion.zip
# unzip ./PhpVersion.zip
Apply the patched file:
# mv ./PhpVersion.php /usr/local/psa/admin/plib/CommonPanel/Aps/Requirement/Plesk/