Plesk is inaccessible after removing postfix or dovecot components via CLI on Debian-based systems

Follow

Comments

6 comments

  • Avatar
    Paul Kottwitz

    Hello,

    whats the status on this product bug.
    I just had to roll back a snapshot of my server when I wanted to uninstall postfix and devecot to install a mailcow server in a docker containter on my root server running debian  where I have running debian.

    br

     

     

    0
    Comment actions Permalink
  • Avatar
    Ivan Postnikov

    Hello @Paul,

    Currently, there is no exact ETA for the fix.

    For now, please, use the workaround from the "Resolution" section: run Plesk installer via CLI and proceed following the instruction, Plesk installer will install the missing package back.

    0
    Comment actions Permalink
  • Avatar
    Paul Kottwitz

    hi @Ivan Postnikov

    so when I uninstall the packs, i can afterwards install plesk via Command Line and postfix and dovecot will not be installed ?

    will take a snapshot and try it out

     

     

    0
    Comment actions Permalink
  • Avatar
    Ivan Postnikov

    @Paul,

    Yes, give it a try.

    0
    Comment actions Permalink
  • Avatar
    Paul Kottwitz

    Negative:
    Running into:

    ===> Cumulative APS controller upgrade (final stage) has been started.
    ===> Cumulative upgrade of APS controller (final stage) has been completed.
    Synchronizing state of sw-engine.service with SysV service script with /lib/systemd/systemd-sysv-install.
    Executing: /lib/systemd/systemd-sysv-install enable sw-engine
    Synchronizing state of sw-cp-server.service with SysV service script with /lib/systemd/systemd-sysv-install.
    Executing: /lib/systemd/systemd-sysv-install enable sw-cp-server
    Synchronizing state of psa.service with SysV service script with /lib/systemd/systemd-sysv-install.
    Executing: /lib/systemd/systemd-sysv-install enable psa
    Synchronizing state of networking.service with SysV service script with /lib/systemd/systemd-sysv-install.
    Executing: /lib/systemd/systemd-sysv-install enable networking
    insserv: Service mountkernfs has to be enabled to start service networking
    insserv: Service urandom has to be enabled to start service networking
    insserv: Service mountkernfs has to be enabled to start service networking
    insserv: Service urandom has to be enabled to start service networking
    insserv: Service mountkernfs has to be enabled to start service networking
    insserv: Service urandom has to be enabled to start service networking
    insserv: Service mountkernfs has to be enabled to start service networking
    insserv: Service urandom has to be enabled to start service networking
    insserv: Service mountkernfs has to be enabled to start service networking
    insserv: Service urandom has to be enabled to start service networking
    insserv: Service mountkernfs has to be enabled to start service networking
    insserv: Service urandom has to be enabled to start service networking
    Stopping sw-cp-server (via systemctl): sw-cp-server.service.
    Starting sw_engine service... done
    Starting sw_cp_server service... done
    Starting mysql service... already started
    Starting named service... already started
    Starting spamfilter service... not installed
    Starting drweb service... not installed
    Starting apache service... done
    Starting xinetd service... already started
    xinetd.service is not a native service, redirecting to systemd-sysv-install.
    Executing: /lib/systemd/systemd-sysv-install enable xinetd
    ===> Configuring ProFTPD server
    Done!
    Module mpm_prefork already disabled
    Module mpm_worker already disabled

    ERROR: Fehler bei der Installation oder dem Upgrade der Erweiterung "Git" (Paket: git):
    sh: 1: /usr/local/psa/bin/extension: not found

    when I do not select git its thwe next in line that throse the error

     

    ERROR: Fehler bei der Installation oder dem Upgrade der Erweiterung "Skins and Color Schemes" (Paket: heavy-metal-skin):
    sh: 1: /usr/local/psa/bin/extension: not found

    Deselekt skins and color: ERROR: Fehler bei der Installation oder dem Upgrade der Erweiterung "Docker" (Paket: docker):
    sh: 1: /usr/local/psa/bin/extension: not found

    0
    Comment actions Permalink
  • Avatar
    Taras Ermoshin

    Hello @Paul Kottwitz!

    You can fix this by manually installing the package 'plesk-core' (the example below is for Plesk Onyx 17.8 on CentOS 7):

    1. Connect to the server using SSH.
    2. Install the package 'plesk-core':

    rpm -Uvh --force https://autoinstall.plesk.com/PSA_17.8.11/dist-rpm-CentOS-7-x86_64/base/plesk-core-17.8.11-cos7.build1708180301.19.x86_64.rpm

    If any other Plesk or operating system is in use, find the required version of the package at https://autoinstall.plesk.com/

    If the issue still persists, consider submitting a support request.

    0
    Comment actions Permalink

Please sign in to leave a comment.

Have more questions? Submit a request