Plesk for Windows
Plesk for Linux
kb: technical
ABT: Group B
Applicable to:
- Plesk for Linux
- Plesk for Windows
Symptoms
- Some functionalities are absent in Plesk interface (Extensions button in the left panel, Subscriptions menu, PHP Settings for a domain, links in Tools & Settings, etc.)
- Change View option to change interface view from Power User to Service Provider is missing in the left bottom corner
Cause
Plesk administrator interface management is locked by enabled Restricted Mode (on Plesk Obsidian) / Custom View (on Plesk Onyx) in Tools & Settings > Restricted Mode Settings/Custom View Settings.
Resolution
-
Go to Tools & Settings > Restricted Mode Settings and untick Enable Restricted Mode:
Note: if you do not see the option Restricted Mode Setting in Tools & Settings refer to the command-line solution.
Command-line solution
-
Run the following command on Linux or Windows server:
# plesk bin poweruser --off -lock false
In case Plesk Web Admin edition is in use, the command should be:
# plesk bin poweruser --on -simple false -lock false
Comments
11 comments
I have done both the GUI and command-line suggestions but the right-hand panel containing "Settings" is still missing. (When I did Tools & Settings > Restricted Mode Settings, the checkbox for Enable Restricted Mode was NOT ticked.) How do I get it back? Plesk Obsidian 18.0.39 on CentOS 7
Hello @Keith Dawson,
It seems you are talking about the right sidebar on the "Websites & Domains" or "Domains > example.com".
You may open it with the following button:
Thanks you, when no answer here I filed a support ticket and got it resolved that way.
The support rep pointed out a survey the developers are running, which appears on that right-hand panel (once you manage to make it appear!). They want to know how people feel about the functions on the right-hand panel, whether & how much they use them. Looks like they made a mistake making it vanish!
Hi there Yaroslav, I had this exact problem yesterday. Thank you very much!
I had both the "symptoms" you described but I admit was mislead by the "resolution" because at first I did not think it was an alternative solution, I thought it was the same web gui command...so after I read a lot of help pages, I tried it and all went back to normal.
May I suggest adding something like "3 - if you cannot see Restricted Mode Settings use the terminal command" in the Resolution section? Maybe can help other faster.
Thanks again
Cheers
Claudio
Hello everyone!
@Keith Dawson, glad to know that the Support Department helped you to sort it out!
@Claudio Januario, thank you for your feedback. Indeed there can be cases when the option Restricted Mode Setting is not visible in GUI. I've added a note in the article as you mentioned!
@... just out of curiosity, is there an explanation for this behaviour? I did absolutely nothing, I do not use restricted mode at all because I maintain my own machine located at a webfarm, I'm the only "client" so I became a little more paranoid about intruders and such. I woke up on the 27th and it was like that.
Any hints appreciated
Cheers
Claudio
@Claudio Januario,it's pretty hard to say what happened initially straight away. I would suggest checking the Action Log (in Tools & Settings) as a first step to understand when the restricted mode was turned on and off. For example, here is what I see on my test server when truing the restricted mode on:
10.32.32.80 admin [2021-12-29 13:17:37] 'Update Administrator Information' ('Client GUID': '106c4724-79a1-4bf4-9674-bd956c77997c' => '106c4724-79a1-4bf4-9674-bd956c77997c', 'Client Type': 'admin' => 'admin', 'Login Name': 'admin' => 'admin')
10.32.32.80 admin [2021-12-29 13:17:37] 'Update Administrator Information' ('Client GUID': '106c4724-79a1-4bf4-9674-bd956c77997c' => '106c4724-79a1-4bf4-9674-bd956c77997c', 'Client Type': 'admin' => 'admin', 'Login Name': 'admin' => 'admin')
10.32.32.80 admin [2021-12-29 13:17:37] 'Update Administrator Information' ('Client GUID': '106c4724-79a1-4bf4-9674-bd956c77997c' => '106c4724-79a1-4bf4-9674-bd956c77997c', 'Client Type': 'admin' => 'admin', 'Login Name': 'admin' => 'admin')
10.32.32.80 admin [2021-12-29 13:17:37] 'Update Administrator Information' ('Client GUID': '106c4724-79a1-4bf4-9674-bd956c77997c' => '106c4724-79a1-4bf4-9674-bd956c77997c', 'Client Type': 'admin' => 'admin', 'Login Name': 'admin' => 'admin')
10.32.32.80 admin [2021-12-29 13:17:37] 'Update Administrator Information' ('Client GUID': '106c4724-79a1-4bf4-9674-bd956c77997c' => '106c4724-79a1-4bf4-9674-bd956c77997c', 'Client Type': 'admin' => 'admin', 'Login Name': 'admin' => 'admin')
10.32.32.80 admin [2021-12-29 13:17:37] 'Update Administrator Information' ('Client GUID': '106c4724-79a1-4bf4-9674-bd956c77997c' => '106c4724-79a1-4bf4-9674-bd956c77997c', 'Client Type': 'admin' => 'admin', 'Login Name': 'admin' => 'admin')
10.32.32.80 admin [2021-12-29 13:17:37] 'Update Administrator Information' ('Client GUID': '106c4724-79a1-4bf4-9674-bd956c77997c' => '106c4724-79a1-4bf4-9674-bd956c77997c', 'Client Type': 'admin' => 'admin', 'Login Name': 'admin' => 'admin')
10.32.32.80 admin [2021-12-29 13:17:37] 'Update Administrator Information' ('Client GUID': '106c4724-79a1-4bf4-9674-bd956c77997c' => '106c4724-79a1-4bf4-9674-bd956c77997c', 'Client Type': 'admin' => 'admin', 'Login Name': 'admin' => 'admin')
10.32.32.80 admin [2021-12-29 13:17:37] 'Update Administrator Information' ('Client GUID': '106c4724-79a1-4bf4-9674-bd956c77997c' => '106c4724-79a1-4bf4-9674-bd956c77997c', 'Client Type': 'admin' => 'admin', 'Login Name': 'admin' => 'admin')
10.32.32.80 admin [2021-12-29 13:17:37] 'Update Administrator Information' ('Client GUID': '106c4724-79a1-4bf4-9674-bd956c77997c' => '106c4724-79a1-4bf4-9674-bd956c77997c', 'Client Type': 'admin' => 'admin', 'Login Name': 'admin' => 'admin')
10.32.32.80 admin [2021-12-29 13:17:37] 'Update domain template by admin' ('Admin template': '1' => '1')
and off:
10.32.32.80 admin [2021-12-29 13:17:46] 'Update Administrator Information' ('Client GUID': '106c4724-79a1-4bf4-9674-bd956c77997c' => '106c4724-79a1-4bf4-9674-bd956c77997c', 'Client Type': 'admin' => 'admin', 'Login Name': 'admin' => 'admin')
10.32.32.80 admin [2021-12-29 13:17:46] 'Update Administrator Information' ('Client GUID': '106c4724-79a1-4bf4-9674-bd956c77997c' => '106c4724-79a1-4bf4-9674-bd956c77997c', 'Client Type': 'admin' => 'admin', 'Login Name': 'admin' => 'admin')
10.32.32.80 admin [2021-12-29 13:17:46] 'Update Administrator Information' ('Client GUID': '106c4724-79a1-4bf4-9674-bd956c77997c' => '106c4724-79a1-4bf4-9674-bd956c77997c', 'Client Type': 'admin' => 'admin', 'Login Name': 'admin' => 'admin')
10.32.32.80 admin [2021-12-29 13:17:46] 'Update Administrator Information' ('Client GUID': '106c4724-79a1-4bf4-9674-bd956c77997c' => '106c4724-79a1-4bf4-9674-bd956c77997c', 'Client Type': 'admin' => 'admin', 'Login Name': 'admin' => 'admin')
10.32.32.80 admin [2021-12-29 13:17:46] 'Update Administrator Information' ('Client GUID': '106c4724-79a1-4bf4-9674-bd956c77997c' => '106c4724-79a1-4bf4-9674-bd956c77997c', 'Client Type': 'admin' => 'admin', 'Login Name': 'admin' => 'admin')
10.32.32.80 admin [2021-12-29 13:17:46] 'Update Administrator Information' ('Client GUID': '106c4724-79a1-4bf4-9674-bd956c77997c' => '106c4724-79a1-4bf4-9674-bd956c77997c', 'Client Type': 'admin' => 'admin', 'Login Name': 'admin' => 'admin')
10.32.32.80 admin [2021-12-29 13:17:46] 'Update Administrator Information' ('Client GUID': '106c4724-79a1-4bf4-9674-bd956c77997c' => '106c4724-79a1-4bf4-9674-bd956c77997c', 'Client Type': 'admin' => 'admin', 'Login Name': 'admin' => 'admin')
10.32.32.80 admin [2021-12-29 13:17:46] 'Update Administrator Information' ('Client GUID': '106c4724-79a1-4bf4-9674-bd956c77997c' => '106c4724-79a1-4bf4-9674-bd956c77997c', 'Client Type': 'admin' => 'admin', 'Login Name': 'admin' => 'admin')
10.32.32.80 admin [2021-12-29 13:17:46] 'Update Administrator Information' ('Client GUID': '106c4724-79a1-4bf4-9674-bd956c77997c' => '106c4724-79a1-4bf4-9674-bd956c77997c', 'Client Type': 'admin' => 'admin', 'Login Name': 'admin' => 'admin')
10.32.32.80 admin [2021-12-29 13:17:46] 'Update Administrator Information' ('Client GUID': '106c4724-79a1-4bf4-9674-bd956c77997c' => '106c4724-79a1-4bf4-9674-bd956c77997c', 'Client Type': 'admin' => 'admin', 'Login Name': 'admin' => 'admin')
10.32.32.80 admin [2021-12-29 13:17:46] 'Update domain template by admin' ('Admin template': '1' => '1')
After that, you may check the other logs and compare the timestamps of different events to identify what happened there and to see if this is somehow related.
The article mentions to disable Restricted Mode on the Restricted Mode Settings page. However that's not where you can enable or disable Restricted Mode. It can found on Tools & Settings > Interface Management.
@Kaspar vd
Restricted mode can be disabled from both Tools & Settings > Restricted Mode Settings and Tools & Settings > Interface Management.
After installing the panel, the first administrator sees all the functions of the site, and the second panel administrator looks like a user - cannot create projects with separate folders on the server (only offers to make part of existing projects), as well as there is no possibility to switch from client mode to hosting provider mode What to do?
@Alex Sev based on your description, you have Additional User Accounts. Such accounts are limited with their own websites/projects. In case you would like to have some administrative rights, consider creating Additional Administrator Account or ask your hosting provider to create it for you.
For more details about both account types, its difference and how to create them, please review this KB article:
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