Applicable to:
- Plesk Onyx for Linux
Symptoms
-
Scheduled backups are not created.
-
Plesk utilities, e.g.:
# plesk login
hang.
-
There are lot of
sw-engine
processes:# ps -e fwww | grep sw-engine
6846 ? S 2:37 _ sw-engine-fpm: pool plesk
6890 ? S 2:37 _ sw-engine-fpm: pool plesk
6903 ? S 2:36 _ sw-engine-fpm: pool plesk
6904 ? S 2:36 _ sw-engine-fpm: pool plesk
6918 ? S 2:36 _ sw-engine-fpm: pool plesk
6920 ? S 2:36 _ sw-engine-fpm: pool plesk
6921 ? S 2:37 _ sw-engine-fpm: pool plesk
6924 ? S 2:36 _ sw-engine-fpm: pool plesk
6936 ? S 2:37 _ sw-engine-fpm: pool plesk
6939 ? S 2:36 _ sw-engine-fpm: pool pleskOR
# ps -e fwww | grep sw-engine
24695 ? Zs 0:00 | _ [sw-engine] <defunct>
24875 ? Zs 0:00 | _ [sw-engine] <defunct>
29217 ? Zs 0:00 | _ [sw-engine] <defunct>
31327 ? Zs 0:00 | _ [sw-engine] <defunct>
15254 ? Zs 0:00 | _ [sw-engine] <defunct>
16243 ? Zs 0:00 | _ [sw-engine] <defunct>
19463 ? Zs 0:00 | _ [sw-engine] <defunct>
20472 ? Zs 0:00 | _ [sw-engine] <defunct>
13502 ? Zs 0:00 | _ [sw-engine] <defunct>
15067 ? Zs 0:00 | _ [sw-engine] <defunct> -
The
strace
output of such processes contains the following:# strace -p6846
<...>
restart_syscall(<... resuming interrupted futex ...>) = -1 ETIMEDOUT (Connection timed out)
fcntl(9, F_SETLKW, {l_type=F_RDLCK, l_whence=SEEK_SET, l_start=0, l_len=0}) = 0
fcntl(7, F_SETLKW, {l_type=F_WRLCK, l_whence=SEEK_SET, l_start=0, l_len=0}) = 0
fcntl(7, F_SETLK, {l_type=F_UNLCK, l_whence=SEEK_SET, l_start=0, l_len=0}) = 0
fcntl(7, F_SETLKW, {l_type=F_WRLCK, l_whence=SEEK_SET, l_start=0, l_len=0}) = 0
fcntl(7, F_SETLK, {l_type=F_UNLCK, l_whence=SEEK_SET, l_start=0, l_len=0}) = 0
umask(02) = 022
stat("/run/lock/lmlib/container_locks/plesk.0/node.1/service", {st_mode=S_IFDIR|S_ISGID|0775, st_size=60, ...}) = 0
umask(022) = 02
umask(0111) = 022
creat("/run/lock/lmlib/container_locks/plesk.0/node.1/service/config.lock", 0777) = 10
close(10) = 0
umask(022) = 0111 -
In case of Multi-Server installation, Service Nodes are going offline periodically during the Daily Maintenance Task execution.
Cause
Product issue:
- #PPPM-8929 "Installation of extensions no longer causes sw-engine scripts and CLI utilities to hang."
Fixed in:- Plesk Onyx 17.8 26 November 2018
- Plesk Obsidian 25 September 2018 (fixed as PPP-37469)
Resolution
Workaround
Upgrade to Plesk Onyx 17.8 or install latest Plesk updates in case already running Plesk Onyx 17.8.
Note: In case it is not possible, see Additional Information section at the bottom.
-
Connect to the server via SSH.
-
Kill all
sw-engine
processes:# pkill sw-engine
-
Restart
sw-cp-server
andsw-engine
services:# service sw-engine restart
# service sw-cp-server restart -
Uninstall New Relic extension:
# plesk bin extension --uninstall new-relic
Additional information
In case upgrade is not an option, try using the ApiCli.zip
from the attachment.
Note that the fix was not fully tested yet was working fine on some installations.
# wget https://support.plesk.com/hc/en-us/article_attachments/360010352974/ApiCli.zip
# unzip ApiCli.zip
# mv /usr/local/psa/admin/plib/pm/ApiCli.php{,.bkp}
# cp -a ApiCli.php /usr/local/psa/admin/plib/pm/
Comments
2 comments
You will not be able to log into Plesk if you kill all sw-engine processes. You'll likely need to start/restart it as well:
pkill sw-engine; systemctl restart sw-engine
or
pkill sw-engine; service sw-engine restart
Hello @Csteamleads,
thank you for noticing. The article will be reviewed and updated soon.
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