Plesk Onyx for Linux
kb: fixed
kb: bug
ABT: Group A
Applicable to:
- Plesk Onyx for Linux
Symptoms
-
Unable to access Plesk > Tools & Settings > Firewall, the error below is shown:
PLESK_ERROR: Error: Permission Denied
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Power User View mode is in use.
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Use Custom View option is enabled in Tools & Settings > Interface management:
Click on the screenshot below to expand -
The Firewall option is enabled in Tools & Settings > Custom View Settings:
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The Extensions option is disabled in Tools & Settings > Custom View Settings:
Cause
Product issue:
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#PPPM-8847 "If, in Restricted Mode Settings, Firewall (under “Tools & Resources”) is selected, while Extensions management (under “Extensions”) is not, going to Tools & Settings > Firewall no longer shows the “permission denied” error when Power User view and Restricted Mode are enabled."
Fixed in:- Plesk Obsidian 15 September 2020 (Linux)
Resolution
Please consider updating your server:
Workaround
If an update is not possible for some reason, please apply the workaround below:
Temporary solution
- Log into Plesk.
- Go to Tools & Settings > Custom View Settings.
- Tick the Extensions option:
- Press the OK button to apply the changes.
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