Applicable to:
- Plesk Onyx for Windows
-
Plesk is unavailable with the following error, when open it in server's browser locally:
CONFIG_TEXT: HTTP Error 500.0 - Internal Server Error
C:\\Program Files (x86)\\Parallels\\Plesk\\admin\\bin\\php-cgi.exe - The FastCGI process exited unexpectedly Detailed Error Information
Module FastCgiModule
Notification ExecuteRequestHandler
Handler PleskEngine-FastCGI-php
Error Code 0xc0000005
Requested URL https://localhost:8443/index.php
Physical Path C:\\Program Files (x86)\\Parallels\\Plesk\\admin\\htdocs\\index.php
Logon Method Anonymous
Logon User Anonymous -
One of the following error can be found in Event viewer > Application:
CONFIG_TEXT: Faulting application name: php-cgi.exe, version: 7.1.14.0, time stamp: 0x5a79309d
Faulting module name: php7.dll, version: 7.1.14.0, time stamp: 0x5a793034
Exception code: 0xc0000005
Fault offset: 0x00000000000c87cd
Faulting process id: 0x1a80
Faulting application start time: 0x01d409f418a8cd48
Faulting application path: C:\Program Files (x86)\Plesk\admin\engine\php-cgi.exe
Faulting module path: C:\Program Files (x86)\Plesk\admin\engine\php7.dll
Report Id: 5657b988-75e7-11e8-968c-020066000003
CONFIG_TEXT: Empty repository file: C:\Program Files (x86)\Plesk\admin\repository\registry.xml
at getWaitTimeout()(`anonymous-namespace'::TokenUpdater::getWaitTimeout line 92)
Execute file name: C:\Program Files (x86)\Plesk\admin\bin\plesksrv.exe -
The following command does not show any output:
C:\> "%plesk_bin%\php.exe" -v
-
The following commands hangs with "Not Responding" error:
C:\> "%plesk_dir%\admin\engine\php.exe" -v
"%plesk_dir%\admin\engine\php-cgi.exe" -v -
The
%plesk_dir%admin\repository\registry.xml
file is empty.
Cause
PHP-CGI crashes on error reporting. While the original issue is corrupted %plesk_dir%\admin\repository\registry.xml
Resolution
-
Connect to the Plesk server via RDP.
-
Go to the
%plesk_dir%admin\repository
folder and rename/remove theregistry.xml
file. -
Go to Windows Start > All Programs > Plesk and open Plesk Services Monitor.
-
In Plesk Services Monitor, mark the Plesk Management Service and click the Restart button.
-
Go to Plesk > Tools & Settings > License Management.
-
Click the Retrieve Keys button.
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