Applicable to:
- Plesk for Linux
Symptoms
-
Plesk UI is not accessible after deploying it from a marketplace image on a cloud hosting service (Alibaba Cloud,Amazon Lightsail, Microsoft Azure), the Maintenance Mode screen is shown:
CONFIG_TEXT: Initializing... [ DONE ]
Cloning... [ 95% ]
Cause
After Plesk is deployed, it installs updates, extensions, etc, which takes time.
Resolution
Warning: Do not restart the server. A reboot can be triggered indirectly by the update of the instance setting, for example by assigning an assigning elastic IP (in case of AWS). Wait for the task to finish.
In case of any doubts, it is possible to double-check that the process is not stuck directly via SSH. For that:
-
Connect to the server via SSH.
Note: If direct SSH access to the server is not possible, contact server administrator for further assistance.
-
Run the following command to track new entries in the installer log (depending on the used cloud service, the log file can be called differently, for example,
/var/log/plesk/azure_setup.log
):# tail -f /var/log/plesk/amazon_setup.log
[...]
==> [Mon May 21 06:10:17 UTC 2018] Update Plesk
[...]
All patches were applied.
Patches were installed successfully.
The changes were applied successfully.
==> [Mon May 21 06:12:56 UTC 2018] Update extensions
==> [Mon May 21 06:13:08 UTC 2018] Update is finished
In case the server was rebooted one way or another, most probably deployment will be stuck. However, it is still possible to get it back to normal by adjusting $maintenance
variable. For that:
Note: the further instructions are intended for server administrators with direct RDP/SSH access to the server.If direct SSH/RDP access to the server is not possible, contact server administrator for further assistance.
Click on a section to expand
-
Connect to the server using SSH.
-
Use any text editor to adjust
/etc/sw-cp-server/conf.d/maintenance
file changing maintenance from "on" to "off". The result should looks like the one below:# cat /etc/sw-cp-server/conf.d/maintenance
$maintenance off; -
Now remove the status.json file that contains the status too:
# rm -rf /usr/local/psa/var/maintenance/status.json
-
Now restart Plesk:
# service sw-cp-server restart
Click on a section to expand
-
Connect to the server via RDP.
- Move to another location
C:\Program Files (x86)\Plesk\var\maintenance\status.json
file. - Reload the browser tab
Comments
1 comment
Thanks a lot this really helped.
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