Applicable to:
- Plesk Onyx for Linux
Symptoms
-
The following error message is shown in Plesk Migrator after subscription migration:
CONFIG_TEXT: Failed to copy content of database 'db_example'
Migration tools tried to perform operation in 3 attempts: Command execution failed on the local server with non-zero exit code.
command: mysql --defaults-file=/usr/local/psa/var/modules/panel-migrator/sessions/20180518015656/target-server/example.cnf -h localhost -P 3306 -uadmin database_site < /usr/local/psa/var/modules/panel-migrator/sessions/20180518015656/target-server/db-dumps/database_site.sql
exit code: 1
stdout:
stderr: ERROR 1118 (42000) at line 421: The size of BLOB/TEXT data inserted in one transaction is greater than 10% of redo log size. Increase the redo log size using innodb_log_file_size
Possible consequences
- Preview of a migrated WordPress domain is not working. WordPress installation is shown instead of the actual domain content.
Cause
Database was not migrated due to insufficient limit for the innodb_log_file_size
parameter in MySQL configuration.
Resolution
-
Connect to the target (destination) Plesk server via SSH.
- Create a backup of the MySQL configuration file
my.cnf
:-
On CentOS/RHEL-based distributions:
# cp -a /etc/my.cnf /etc/my.cnf.back
-
On Debian/Ubuntu-based distributions:
# cp -a /etc/mysql/my.cnf /etc/mysql/my.cnf.back
-
-
Open the original
my.cnf
file in any text editor. In this example, we are using the vi editor:-
On CentOS/RHEL-based distributions:
# vi /etc/my.cnf
-
On Debian/Ubuntu-based distributions:
# vi /etc/mysql/my.cnf
-
-
Increase the limit of the
innodb_log_file_size
parameter (or set it anew if it does not exist) in the [mysqld] section:CONFIG_TEXT: [mysqld]
innodb_log_file_size=50M
[...] -
Save the changes and close the file.
-
Restart MySQL using an appropriate command (Depends on operating system):
# service mysqld restart
# service mysql restart
# service mariadb restart
-
Re-sync the subscription in Plesk Migrator at Tools & Settings > Migration & Transfer Manager > select the current migration and click Re-sync next to the subscription in question.
Note: If the issue remains, increase the
innodb_log_file_size
limit to a greater value.
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