Applicable to:
- Plesk for Linux
Symptoms
-
cURL utility does not work on the Plesk server.
- Other tools are able to resolve the hostname properly.
-
Unable to open PHP page that uses cURL:
CONFIG_TEXT: Could not resolve host: example.com: Name or service not known
-
CentOS/RHEL was upgraded to the newer version
-
OpenSSL packages were updated recently:
# grep -i ssl /var/log/yum.log
Updated: 1:openssl-libs-1.0.2k-12.el7.x86_64
Updated: 1:openssl-1.0.2k-12.el7.x86_64 -
glibc package was updated recently:
# grep -i glibc /var/log/yum.log
Updated: 1:glibc-2.17-196.el7_4.2.x86_64
Updated: 1 -
Cannot issue Let's Encrypt certificate:
CONFIG_TEXT: ERR [extension/letsencrypt] Domain validation failed: Could not obtain directory: cURL error 6: Could not resolve host: acme-v01.api.letsencrypt.org; Name or service not known
-
Plesk license cannot be updated:
CONFIG_TEXT: license server https://id-00.kaid.plesk.com:443/ (): Couldn't resolve host name(6) cURL cannot communicate with license server https://id-00.kaid.plesk.com:443/ (): Couldn't resolve host name(6) (Error code: 2)
-
Unable to add domains to Cloudflare with Cloudflare ServerShield extension.
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Unable to install a license key in Tools & Settings > License Management > Install Key. Following error message appears in Plesk interface:
Error: cURL cannot communicate with license server https://id-00.kaid.plesk.com:5224/ (): Couldn't resolve host name(6) cURL cannot communicate with license server https://id-00.kaid.plesk.com:5224/ (): Couldn't resolve host name(6)
-
In some cases license can be successfully installed via CLI with the following command:
# plesk bin license -i AAAAA-BBBBB-CCCCC-DDDDD-EEEEE
Cause
Shared libraries used by curl were updated, for example: OpenSSL, glibc.
Resolution
Click on a section to expand
- Log in to Plesk.
- Navigate to Tools & Settings > Server Management > Restart Server:
Alternatively, restart required services one by one:
-
Log into Plesk.
-
Navigate to Tools & Settings > Server Management > Services Management
-
Click on 'Restart' button for each FPM service, Apache and Nginx:
Note: Restart of Plesk services (sw-cp-server and sw-engine) is possible only from the command-line interface.
-
Restart the services:
# systemctl restart sw-engine sw-cp-server httpd nginx php-fpm plesk-php72-fpm
Note: restart other FPM-services if used, execute the command below:
# plesk bin php_handler --list | grep -E plesk.*fpm | awk -F" " '{ print $1 }' | while read i; do service $i restart; done
-
If this does not help, reboot the server:
# reboot
Comments
12 comments
Thank you. I had the same problem, but that was after Plesk updated the CENTOS.
It would be nice when updates through Plesk of the OS (CENTOS) automatically restarted the updated services
Henk
Hi,
I agree with Henk. It would be nice when Plesk update CentOS packages, that automatically restarted the updated services and services which uses files of updated packages.
Regards, Miha
"H.W. Bartels" i agree, Plesk should restart automatically the updated services when certain updates of the OS through Plesk require a restart of these services.
Hi! i restarted the FPM service, Apache and Nginx via PLESK, but still not working for me, I try to put a lets encrypt certificate to a new domain and says this:
Error: Could not issue a Let's Encrypt SSL/TLS certificate for tombrownsmagaluf.com.
Details
Hello @Miha, @Gianluca!
Currently, the optimal solution is under consideration.
Click "Follow" to be notified when this article will be updated.
@JL Detan
It should work now. Such issues were caused by planned maintenance of Let's Encrypt server side. Check out this article for more info - https://support.plesk.com/hc/en-us/articles/115004456013
Me gustaria sabre si Funciona la solucion, ya Que ya indicados reinicie Servicios los, Menos el Servidor
¿Es necesario reiniciar el servidor completamente?
Hello @Alan, usually it is enough to restart services listed in the article only.
However, we have already met cases when only server restart resolved the issue completely.
Please, restart the server and let us know if the issue persists.
Hi, for me worked restarting the server, now all works fine, thanks
Hello @JL Detan, glad to know that the issue is resolved.
Buenas tardes, he resuelto mi problema, Hice clic en el botón 'Reiniciar' para cada servicio FPM, Apache y Nginx:, no hubo necesidad de reiniciar el server, y la licencia respondió bien, agradezco el aporte y la orientación al mismo.
Hello @Alan, glad to know that the article helped and no server restart was required in your case.
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