The "plesk repair installation" utility shows warnings on debian-based OSes: "failed to get permissions for package diverts others to" OR "Skip fixing"

Follow

Comments

2 comments

  • Avatar
    b_p

    Actually, the list of WARNINGs is much longer at the moment (at least with Ubuntu 16.04.5 LTS):

    WARNING:Skip fixing 'libapache2-mod-aclr2-psa': Cannot find deb-archive for package libapache2-mod-aclr2-psa (14081815-ubuntu16.04.17100418.9e86c2f)
    WARNING:failed to get permissions for package diverts others to: /usr/lib/apache2/modules/mod_proxy.so.orig from package /var/cache/apt/archives/libapache2-mod-proxy-psa_2.4.18-ubuntu16.04.17100418_amd64.deb
    WARNING:failed to get permissions for package diverts others to: /usr/lib/apache2/modules/mod_proxy_fcgi.so.orig from package /var/cache/apt/archives/libapache2-mod-proxy-psa_2.4.18-ubuntu16.04.17100418_amd64.deb
    WARNING:Skip fixing 'libapache2-mod-sysenv-psa': Cannot find deb-archive for package libapache2-mod-sysenv-psa (0.2-ubuntu16.04.17100418)
    WARNING:Skip fixing 'libaps': Cannot find deb-archive for package libaps (1.0.9-ubuntu.16.04.180209.1429)
    WARNING:Skip fixing 'liblog4cplus': Cannot find deb-archive for package liblog4cplus (1.2.0.1-ubuntu.16.04.180209.1429)
    WARNING:Skip fixing 'libpam-plesk': Cannot find deb-archive for package libpam-plesk (17.8.11-ubuntu16.04.build1708180301.19)
    WARNING:Skip fixing 'php-ioncube-loader': Cannot find deb-archive for package php-ioncube-loader (10.0.3-ubuntu16.04.18021914)
    WARNING:Skip fixing 'plesk-base': Cannot find deb-archive for package plesk-base (17.8.11-ubuntu16.04.build1708180301.19)
    WARNING:Skip fixing 'plesk-completion': Cannot find deb-archive for package plesk-completion (17.8.11-ubuntu16.04.build1708180322.11)
    WARNING:Skip fixing 'plesk-config-troubleshooter': Cannot find deb-archive for package plesk-config-troubleshooter (17.8.11-ubuntu16.04.build1708190219.21)
    WARNING:Skip fixing 'plesk-core': Cannot find deb-archive for package plesk-core (17.8.11-ubuntu16.04.build1708180301.19)
    WARNING:Skip fixing 'plesk-distupgrade': Cannot find deb-archive for package plesk-distupgrade (17.8.11-ubuntu.16.04.180301.1930)
    WARNING:Skip fixing 'plesk-dns-bind-driver': Cannot find deb-archive for package plesk-dns-bind-driver (17.8.11-ubuntu16.04.build1708180301.19)
    WARNING:Skip fixing 'plesk-ext-catalog': Cannot find deb-archive for package plesk-ext-catalog (1.1.0-148.18030120)
    WARNING:Skip fixing 'plesk-ext-rest-api': Cannot find deb-archive for package plesk-ext-rest-api (1.0.0-32.18030120)
    WARNING:Skip fixing 'plesk-fail2ban-configurator': Cannot find deb-archive for package plesk-fail2ban-configurator (17.8.11-ubuntu16.04.build1708180212.17)
    WARNING:Skip fixing 'plesk-l10n': Cannot find deb-archive for package plesk-l10n (17.8.11-ubuntu16.04.build1708181025.13)
    WARNING:Skip fixing 'plesk-libboost-1.65': Cannot find deb-archive for package plesk-libboost-1.65 (1.65.1-ubuntu.16.04.171017.1047)
    WARNING:Skip fixing 'plesk-libboost-atomic1.65': Cannot find deb-archive for package plesk-libboost-atomic1.65 (1.65.1-ubuntu.16.04.171017.1047)
    WARNING:Skip fixing 'plesk-libboost-chrono1.65': Cannot find deb-archive for package plesk-libboost-chrono1.65 (1.65.1-ubuntu.16.04.171017.1047)
    WARNING:Skip fixing 'plesk-libboost-date-time1.65': Cannot find deb-archive for package plesk-libboost-date-time1.65 (1.65.1-ubuntu.16.04.171017.1047)
    WARNING:Skip fixing 'plesk-libboost-filesystem1.65': Cannot find deb-archive for package plesk-libboost-filesystem1.65 (1.65.1-ubuntu.16.04.171017.1047)
    WARNING:Skip fixing 'plesk-libboost-iostreams1.65': Cannot find deb-archive for package plesk-libboost-iostreams1.65 (1.65.1-ubuntu.16.04.171017.1047)
    WARNING:Skip fixing 'plesk-libboost-log1.65': Cannot find deb-archive for package plesk-libboost-log1.65 (1.65.1-ubuntu.16.04.171017.1047)
    WARNING:Skip fixing 'plesk-libboost-program-options1.65': Cannot find deb-archive for package plesk-libboost-program-options1.65 (1.65.1-ubuntu.16.04.171017.1047)
    WARNING:Skip fixing 'plesk-libboost-regex1.65': Cannot find deb-archive for package plesk-libboost-regex1.65 (1.65.1-ubuntu.16.04.171017.1047)
    WARNING:Skip fixing 'plesk-libboost-serialization1.65': Cannot find deb-archive for package plesk-libboost-serialization1.65 (1.65.1-ubuntu.16.04.171017.1047)
    WARNING:Skip fixing 'plesk-libboost-system1.65': Cannot find deb-archive for package plesk-libboost-system1.65 (1.65.1-ubuntu.16.04.171017.1047)
    WARNING:Skip fixing 'plesk-libboost-thread1.65': Cannot find deb-archive for package plesk-libboost-thread1.65 (1.65.1-ubuntu.16.04.171017.1047)
    WARNING:Skip fixing 'plesk-liblog4cpp-0.3.5': Cannot find deb-archive for package plesk-liblog4cpp-0.3.5 (0.3.5rc2-ubuntu.16.04.171017.1348)
    WARNING:Skip fixing 'plesk-libmariadbclient-1.0': Cannot find deb-archive for package plesk-libmariadbclient-1.0 (1.0.0-ubuntu.16.04.171006.1040)
    WARNING:Skip fixing 'plesk-libmyodbc': Cannot find deb-archive for package plesk-libmyodbc (5.2.7-ubuntu16.04.17091320)
    WARNING:Skip fixing 'plesk-libpoco-1.7.8': Cannot find deb-archive for package plesk-libpoco-1.7.8 (1.7.8p3-ubuntu.16.04.171017.1159)
    WARNING:Skip fixing 'plesk-librdbmspp': Cannot find deb-archive for package plesk-librdbmspp (2.0.2-ubuntu.16.04.180209.1429)
    WARNING:Skip fixing 'plesk-libstdc++6.3.0': Cannot find deb-archive for package plesk-libstdc++6.3.0 (6.3.0-ubuntu.16.04.171005.2356)
    WARNING:Skip fixing 'plesk-lmlib': Cannot find deb-archive for package plesk-lmlib (0.2.4-ubuntu.16.04.180209.1429)
    WARNING:Skip fixing 'plesk-mail-pc-driver': Cannot find deb-archive for package plesk-mail-pc-driver (17.8.11-ubuntu16.04.build1708180927.11)
    WARNING:Skip fixing 'plesk-milter': Cannot find deb-archive for package plesk-milter (8.14.5-ubuntu.16.04.171117.1614)
    WARNING:failed to get permissions for /etc/apache2/modsecurity.d/rules/modsecurity_crs-plesk/modsecurity_crs_10_setup.conf from package /var/cache/apt/archives/plesk-modsecurity-crs_17.8.11-ubuntu16.04.18021217_amd64.deb
    WARNING:failed to get permissions for /etc/apache2/modsecurity.d/rules/modsecurity_crs-plesk/modsecurity_crs_47_common_exceptions.conf from package /var/cache/apt/archives/plesk-modsecurity-crs_17.8.11-ubuntu16.04.18021217_amd64.deb
    WARNING:failed to get permissions for /etc/apache2/modsecurity.d/rules/modsecurity_crs-plesk/modsecurity_crs_40_generic_attacks.conf from package /var/cache/apt/archives/plesk-modsecurity-crs_17.8.11-ubuntu16.04.18021217_amd64.deb
    WARNING:failed to get permissions for /etc/apache2/modsecurity.d/rules/modsecurity_crs-plesk/modsecurity_crs_23_request_limits.conf from package /var/cache/apt/archives/plesk-modsecurity-crs_17.8.11-ubuntu16.04.18021217_amd64.deb
    WARNING:failed to get permissions for /etc/apache2/modsecurity.d/rules/modsecurity_crs-plesk/modsecurity_crs_21_protocol_anomalies.conf from package /var/cache/apt/archives/plesk-modsecurity-crs_17.8.11-ubuntu16.04.18021217_amd64.deb
    WARNING:failed to get permissions for /etc/apache2/modsecurity.d/rules/modsecurity_crs-plesk/modsecurity_crs_41_xss_attacks.conf from package /var/cache/apt/archives/plesk-modsecurity-crs_17.8.11-ubuntu16.04.18021217_amd64.deb
    WARNING:failed to get permissions for /etc/apache2/modsecurity.d/rules/modsecurity_crs-plesk/modsecurity_crs_59_outbound_blocking.conf from package /var/cache/apt/archives/plesk-modsecurity-crs_17.8.11-ubuntu16.04.18021217_amd64.deb
    WARNING:failed to get permissions for /etc/apache2/modsecurity.d/rules/modsecurity_crs-plesk/modsecurity_crs_45_trojans.conf from package /var/cache/apt/archives/plesk-modsecurity-crs_17.8.11-ubuntu16.04.18021217_amd64.deb
    WARNING:failed to get permissions for /etc/apache2/modsecurity.d/rules/modsecurity_crs-plesk/modsecurity_crs_41_sql_injection_attacks.conf from package /var/cache/apt/archives/plesk-modsecurity-crs_17.8.11-ubuntu16.04.18021217_amd64.deb
    WARNING:failed to get permissions for /etc/apache2/modsecurity.d/rules/modsecurity_crs-plesk/modsecurity_crs_20_protocol_violations.conf from package /var/cache/apt/archives/plesk-modsecurity-crs_17.8.11-ubuntu16.04.18021217_amd64.deb
    WARNING:failed to get permissions for /etc/apache2/modsecurity.d/rules/modsecurity_crs-plesk/modsecurity_40_generic_attacks.data from package /var/cache/apt/archives/plesk-modsecurity-crs_17.8.11-ubuntu16.04.18021217_amd64.deb
    WARNING:failed to get permissions for /etc/apache2/modsecurity.d/rules/modsecurity_crs-plesk/modsecurity_50_outbound.data from package /var/cache/apt/archives/plesk-modsecurity-crs_17.8.11-ubuntu16.04.18021217_amd64.deb
    WARNING:failed to get permissions for /etc/apache2/modsecurity.d/rules/modsecurity_crs-plesk/modsecurity_50_outbound_malware.data from package /var/cache/apt/archives/plesk-modsecurity-crs_17.8.11-ubuntu16.04.18021217_amd64.deb
    WARNING:failed to get permissions for /etc/apache2/modsecurity.d/rules/modsecurity_crs-plesk/modsecurity_crs_42_tight_security.conf from package /var/cache/apt/archives/plesk-modsecurity-crs_17.8.11-ubuntu16.04.18021217_amd64.deb
    WARNING:failed to get permissions for /etc/apache2/modsecurity.d/rules/modsecurity_crs-plesk/modsecurity_crs_30_http_policy.conf from package /var/cache/apt/archives/plesk-modsecurity-crs_17.8.11-ubuntu16.04.18021217_amd64.deb
    WARNING:failed to get permissions for /etc/apache2/modsecurity.d/rules/modsecurity_crs-plesk/modsecurity_crs_35_bad_robots.conf from package /var/cache/apt/archives/plesk-modsecurity-crs_17.8.11-ubuntu16.04.18021217_amd64.deb
    WARNING:failed to get permissions for /etc/apache2/modsecurity.d/rules/modsecurity_crs-plesk/modsecurity_crs_60_correlation.conf from package /var/cache/apt/archives/plesk-modsecurity-crs_17.8.11-ubuntu16.04.18021217_amd64.deb
    WARNING:failed to get permissions for /etc/apache2/modsecurity.d/rules/modsecurity_crs-plesk/modsecurity_35_bad_robots.data from package /var/cache/apt/archives/plesk-modsecurity-crs_17.8.11-ubuntu16.04.18021217_amd64.deb
    WARNING:failed to get permissions for /etc/apache2/modsecurity.d/rules/modsecurity_crs-plesk/modsecurity_crs_49_inbound_blocking.conf from package /var/cache/apt/archives/plesk-modsecurity-crs_17.8.11-ubuntu16.04.18021217_amd64.deb
    WARNING:failed to get permissions for /etc/apache2/modsecurity.d/rules/modsecurity_crs-plesk/modsecurity_35_scanners.data from package /var/cache/apt/archives/plesk-modsecurity-crs_17.8.11-ubuntu16.04.18021217_amd64.deb
    WARNING:failed to get permissions for /etc/apache2/modsecurity.d/rules/modsecurity_crs-plesk/modsecurity_crs_48_local_exceptions.conf.example from package /var/cache/apt/archives/plesk-modsecurity-crs_17.8.11-ubuntu16.04.18021217_amd64.deb
    WARNING:failed to get permissions for /etc/apache2/modsecurity.d/rules/modsecurity_crs-plesk/modsecurity_crs_50_outbound.conf from package /var/cache/apt/archives/plesk-modsecurity-crs_17.8.11-ubuntu16.04.18021217_amd64.deb
    WARNING:Skip fixing 'plesk-nodejs7': Cannot find deb-archive for package plesk-nodejs7 (7.4.0-17011719)
    WARNING:failed to get permissions for /etc/init.d/plesk-php72-fpm from package /var/cache/apt/archives/plesk-php72-fpm_1%3a7.2.16-ubuntu.16.04.190311.1059_amd64.deb
    WARNING:Skip fixing 'plesk-platform-runtime': Cannot find deb-archive for package plesk-platform-runtime (1.0.2-ubuntu.16.04.180209.1429)
    WARNING:Skip fixing 'plesk-release': Cannot find deb-archive for package plesk-release (17.8.11-ubuntu16.04.build1708180301.19)
    WARNING:Skip fixing 'plesk-resctrl': Cannot find deb-archive for package plesk-resctrl (17.8.11-ubuntu16.04.build1708180301.19)
    WARNING:failed to get permissions for /usr/share/psa-roundcube/plugins/sieverules/config.inc.php from package /var/cache/apt/archives/plesk-roundcube_1.3.6-ubuntu16.04.build1708180427.13_all.deb
    WARNING:Skip fixing 'plesk-skins': Cannot find deb-archive for package plesk-skins (17.8.11-ubuntu16.04.build1708180925.11)
    WARNING:Skip fixing 'plesk-web-hosting': Cannot find deb-archive for package plesk-web-hosting (17.8.11-ubuntu16.04.build1708180301.19)
    WARNING:Skip fixing 'plesk-wp-upgrade': Cannot find deb-archive for package plesk-wp-upgrade (1.0-71.17061317)
    WARNING:Skip fixing 'pp17.0.17-bootstrapper': Cannot find deb-archive for package pp17.0.17-bootstrapper (17.0.17-ubuntu16.04.build1700170322.17)
    WARNING:Skip fixing 'pp17.5.3-bootstrapper': Cannot find deb-archive for package pp17.5.3-bootstrapper (17.5.3-ubuntu16.04.build1705170317.16)
    WARNING:Skip fixing 'psa': Cannot find deb-archive for package psa (17.8.11-ubuntu16.04.build1708180301.19)
    WARNING:Skip fixing 'psa-autoinstaller': Cannot find deb-archive for package psa-autoinstaller (3.22.14-ubuntu.16.04.190117.1649)
    WARNING:Skip fixing 'psa-drweb-configurator': Cannot find deb-archive for package psa-drweb-configurator (17.8.11-ubuntu16.04.build1708180301.19)
    WARNING:Skip fixing 'psa-firewall': Cannot find deb-archive for package psa-firewall (17.8.11-ubuntu16.04.build1708180301.19)
    WARNING:Skip fixing 'psa-health-monitor': Cannot find deb-archive for package psa-health-monitor (17.8.11-ubuntu16.04.build1708180417.15)
    WARNING:Skip fixing 'psa-libxml-proxy': Cannot find deb-archive for package psa-libxml-proxy (2.9.7-ubuntu16.04.18021314)
    WARNING:Skip fixing 'psa-locale-base-en-us': Cannot find deb-archive for package psa-locale-base-en-us (17.8.11-ubuntu16.04.build1708181211.16)
    WARNING:Skip fixing 'psa-logrotate': Cannot find deb-archive for package psa-logrotate (3.8.2-ubuntu16.04.build1708171004.18)
    WARNING:Skip fixing 'psa-mail-driver-common': Cannot find deb-archive for package psa-mail-driver-common (17.8.11-ubuntu16.04.build1708181205.19)
    WARNING:Skip fixing 'psa-php-configurator': Cannot find deb-archive for package psa-php-configurator (1.7.0-ubuntu16.04.build1708180212.17)
    WARNING:Skip fixing 'psa-phpmyadmin': Cannot find deb-aWARNING:Skip fixing 'psa-phpmyadmin': Cannot find deb-archive for package psa-phpmyadmin (4.8.4-ubuntu16.04.build1708181212.18)
    WARNING:Skip fixing 'psa-pylibplesk': Cannot find deb-archive for package psa-pylibplesk (17.8.11-ubuntu16.04.build1708180301.19)
    WARNING:Skip fixing 'psa-spamassassin': Cannot find deb-archive for package psa-spamassassin (17.8.11-ubuntu16.04.build1708180301.19)
    WARNING:Skip fixing 'psa-vhost': Cannot find deb-archive for package psa-vhost (17.8.11-ubuntu16.04.build1708180425.13)
    WARNING:Skip fixing 'psa-watchdog': Cannot find deb-archive for package psa-watchdog (17.8.11-ubuntu16.04.build1708190221.14)
    WARNING:Skip fixing 'sw-collectd': Cannot find deb-archive for package sw-collectd (5.5.0.1-ubuntu16.04.18021213)
    WARNING:Skip fixing 'sw-cp-server': Cannot find deb-archive for package sw-cp-server (2.5.1-ubuntu16.04.18012916)
    WARNING:Skip fixing 'sw-engine': Cannot find deb-archive for package sw-engine (2.24.12-ubuntu.16.04.190212.1352)
    WARNING:Skip fixing 'sw-engine-cli-2.20': Cannot find deb-archive for package sw-engine-cli-2.20 (2.20.2-ubuntu1604.201612081611)
    WARNING:Skip fixing 'sw-engine-cli-2.21': Cannot find deb-archive for package sw-engine-cli-2.21 (2.21.0-ubuntu1604.201702161522)
    WARNING:Skip fixing 'sw-engine-cli-2.24': Cannot find deb-archive for package sw-engine-cli-2.24 (2.24.12-ubuntu.16.04.190212.1352)
    WARNING:Skip fixing 'sw-libboost-date-time1.55.0': Cannot find deb-archive for package sw-libboost-date-time1.55.0 (1.55.0-ubuntu16.04.16060318)
    WARNING:Skip fixing 'sw-libboost-filesystem1.55.0': Cannot find deb-archive for package sw-libboost-filesystem1.55.0 (1.55.0-ubuntu16.04.16060318)
    WARNING:Skip fixing 'sw-libboost-iostreams1.55.0': Cannot find deb-archive for package sw-libboost-iostreams1.55.0 (1.55.0-ubuntu16.04.16060318)
    WARNING:Skip fixing 'sw-libboost-program-options1.55.0': Cannot find deb-archive for package sw-libboost-program-options1.55.0 (1.55.0-ubuntu16.04.16060318)
    WARNING:Skip fixing 'sw-libboost-regex1.55.0': Cannot find deb-archive for package sw-libboost-regex1.55.0 (1.55.0-ubuntu16.04.16060318)
    WARNING:Skip fixing 'sw-libboost-serialization1.55.0': Cannot find deb-archive for package sw-libboost-serialization1.55.0 (1.55.0-ubuntu16.04.16060318)
    WARNING:Skip fixing 'sw-libboost-system1.55.0': Cannot find deb-archive for package sw-libboost-system1.55.0 (1.55.0-ubuntu16.04.16060318)
    WARNING:Skip fixing 'sw-libboost-thread1.55.0': Cannot find deb-archive for package sw-libboost-thread1.55.0 (1.55.0-ubuntu16.04.16060318)
    WARNING:Skip fixing 'sw-libmilter': Cannot find deb-archive for package sw-libmilter (8.14.5.1-ubuntu16.04.16102515)
    WARNING:Skip fixing 'sw-libpoco': Cannot find deb-archive for package sw-libpoco (1.4.3p1.1-ubuntu16.04.16061715)
    WARNING:Skip fixing 'sw-librrd': Cannot find deb-archive for package sw-librrd (1.6.0.1-ubuntu16.04.18012211)
    WARNING:Skip fixing 'sw-rrdtool': Cannot find deb-archive for package sw-rrdtool (1.6.0.1-ubuntu16.04.18012211)
    WARNING:Skip fixing 'sw-tar': Cannot find deb-archive for package sw-tar (1.29-2.ubuntu16.04.17051015)

  • Avatar
    Ekaterina Babenko

    Hello,

    Yes, the list may contain more warnings than described in the article. For convenience, all of them are not added. However, I put corresponding note for better capturing the issue.

Please sign in to leave a comment.

Have more questions? Submit a request