Extensions menu is missing after the upgrade from Onyx 17.5 to Onyx 17.8

Follow

Comments

7 comments

  • Avatar
    Unknown User

    I have tried this fix, but the Extensions menu is still missing. I am currently running Plesk 17.8.11 Update #31. Is there any resolution or anything else I can try?

  • Avatar
    Unknown User

    We've done this:
    sudo plesk bin extension -i /usr/local/psa/var/ext-catalog.zip
    sudo plesk db "update Modules set plesk_max_version = ''"
    sudo plesk daily UpgradeExtensions

    And we've done this:
    sudo plesk repair installation

    Also tried this without any luck:
    sudo plesk installer --select-release-current --reinstall-patch --upgrade-installed-components

  • Avatar
    Alexandr Redikultsev

    Hi @Steve Cencula,

    Maybe it is custom view limitation?

    Try executing the following commands in order to check it:

    # plesk bin poweruser --on -simple -false

    or 

    # plesk bin poweruser --off

  • Avatar
    Unknown User

    Nope. Tried both and still no Extensions menu or Let's Encrypt icons in the domain menus.

  • Avatar
    Alisa Kasyanova

    @Steve Cencula
    Try to execute the commands again, but change the "plesk bin extension -i /usr/local/psa/var/ext-catalog.zip" to "plesk bin extension -i catalog". If it won't help, please feel free to submit a support request as per https://support.plesk.com/hc/en-us/articles/213608509-How-to-submit-a-request-to-Plesk-support- or https://support.plesk.com/hc/en-us/articles/213953025

  • Avatar
    Steve Cencula

    This problem has cropped-up again for us from time to time. Here's what we  do to fix it, in case it helps anyone else:

    sudo plesk bin extension -i /usr/local/psa/var/ext-catalog.zip
    sudo plesk db "update Modules set plesk_max_version = ''"
    sudo plesk bin extension -l   <--this shows installed extensions
    sudo plesk bin extension -i letsencrypt <-- this reinstall any extensions that may be causing problems
    sudo plesk repair fs -verbose <-- this fixes permissions

    umask 0022
    umask -S

    sudo service sw-engine restart

  • Avatar
    Maxim Krasikov

    Hello @Steve Cencula

    If you face the same issue again, please contact Plesk support for assistance.
    We would like to investigate such behaviour:
    https://support.plesk.com/hc/en-us/requests/new

Please sign in to leave a comment.

Have more questions? Submit a request