Does Plesk support Ubuntu 18.04?

Follow

Comments

23 comments

  • Avatar
    Mitchell van Bijleveld

    I would like to see an ETA. Don't say you don't know an ETA because I'm sure you have already planned support for 18.04, at least very limited.

  • Avatar
    Ivan Postnikov

    Hello @Mitchell van Bijleveld, developers are currently working on it. The required OS version is expected to be supported by the end of this quarter or earlier.

  • Avatar
    Dick Postma

    @ivan Any update on this issue? We have brand new Lenovo hardware wich is only is supported in Ubuntu 17 or higher. 

  • Avatar
    Alexandr Redikultsev

    Hello, @Dick Postma!

    The support of Ubuntu 18 is expected in the next micro update of Plesk Onyx 17.8 that should be available on the next week.

    Subscribe to this article to be notified right after Ubuntu 18 will be supported.

  • Avatar
    Pablo Ramoz

    Is there a Ubuntu 18.04 Plesk ISO planned to be released at the time of support?

  • Avatar
    Ferry van Steen

    Any chance of a PHP 5.6 package?

    Can't really run without it yet unfortunately.

  • Avatar
    Ivan Postnikov

    Hello @Pablo, currently there are no such plans.
    All ways to install Plesk are described here.

  • Avatar
    Ioan Agopian

    Any news on PostgreSQL support with Ubuntu 18.04?

  • Avatar
    Ivan Postnikov

    Hello @Ioan, The resolution is still in progress. After PostgreSQL fix, the article will be updated.

  • Avatar
    Matt Downer

    I am still running Ubuntu Server 14.04.5 LTS. We are migrating to a new server farm. Should I stay on 14.04.5 LTS or move to Ubuntu 16.04 Server LTS for better security since this 18.04 LTS nightmare seems like it going to be ongoing for many more months... Thoughts everyone?

     

  • Avatar
    Ivan Postnikov

    Hello @Matt, I would suggest picking the newer OS version instead of Ubuntu 14.04 due to longer support. The choice between 16.04 and 18.04 is up to you, bearing in mind current limitations of Ubuntu 18.04

  • Avatar
    Marco Morganti

    Any news for the full support of 18.04.01?

     

  • Avatar
    Ivan Postnikov

    @Marco, there is no exact date but the article will be updated accordingly.

  • Avatar
    Liwindo (Edited )

    Any news according to the MySQL Topic?

  • Avatar
    Matt Downer

    Still no update. Is it time to leave Plesk if they are not staying with current OS builds?

  • Avatar
    Alexandr Redikultsev

    Hi @Liwindo

    By default Plesk deploys MariaDB on a clean server. If there is a reason for you to use MySQL, instead of MariaDB, you can either install it before Plesk installation or try to replace MariaDB with MySQL. Do not forget to create a snapshot of the server as replacing packages even without dependencies might lead to some issues.

  • Avatar
    Anzhelika Khapaknysh

    Hello @Matt Downer!

    We're working on full support of Ubuntu 18.
    The last update of Docker extension allows using it on Ubuntu 18.

    The article has been updated accordingly.

    In case mentioned limitations are unacceptable for you, I'd recommend installing Plesk on another OSes.

  • Avatar
    Henri Pelkonen

    Hi! Is cgroups support also coming to Ubuntu 18 and when?

  • Avatar
    Robert Asilbekov

    @Henri Pelkonen cgroups is supported on Ubuntu 18 in Plesk Onyx 17.8. 

  • Avatar
    Henri Pelkonen

    Thanks, good to know. Should you update the info then ie:
    https://www.plesk.com/extensions/plesk-cgroups-manager/

  • Avatar
    Alexandr Redikultsev

    Hi @Henri Pelkonen,

    Thanks for spotting it!

    We will update the information there.

  • Avatar
    Ioan Agopian

    Any news on PostgreSQL support on Ubuntu 18?

  • Avatar
    Alisa Kasyanova

    @Ioan Agopian
    PostgeSQL will be supported in Plesk 17.9 on Ubuntu 18. We do not have any ETA when the fix will be backported to Plesk Onyx 17.8, since such backport requires significant changes, including changes in the product's business logic. Please subscribe to this article to receive a notification when the backport will be available: https://support.plesk.com/hc/en-us/articles/360006750733-Unable-to-configure-PostgreSQL-in-Plesk-Onyx-on-Ubuntu-18-04-The-test-connection-to-the-database-server-has-failed

Please sign in to leave a comment.

Have more questions? Submit a request