Applicable to:
- Plesk for Linux
Symptoms
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Fail2Ban is installed and enabled in Plesk.
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When opening Plesk or a website or logging in to an email account via webmail from a specific IP address (for example, 203.0.113.2), the connection fails:
CONFIG_TEXT: ERR_CONNECTION_TIMED_OUT
CONFIG_TEXT: ERR_CONNECTION_REFUSED
CONFIG_TEXT: This site can’t be reached
203.0.113.2 took too long to respond. -
From other IP addresses Plesk, websites and email accounts are accessible.
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The following error message may appear in Plesk during some operation:
PLESK_ERROR: Request to backend API failed with error: Network error
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The IP address 203.0.113.2 can be found in Plesk at Tools & Settings > IP Address Banning (Fail2Ban) > Banned IP Addresses or via CLI:
# plesk bin ip_ban --banned
Banned IP addresses:
203.0.113.2 plesk-panel Jan 1, 2020
Cause
The user's IP address has been banned by Fail2Ban.
Resolution
Unban the IP-address or add it to trusted IP-addresses
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Log in to Plesk from a different IP address (another device).
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Go to Tools & Settings > IP Address Banning (Fail2Ban) > Banned IP Addresses.
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Select the user's IP address and click Unban or Move to Trusted IPs.
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Connect to the Plesk server via SSH.
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Unban the user's IP address:
# plesk bin ip_ban --unban 203.0.113.2
SUCCESS: The selected IP addresses were unbanned. -
Add the IP address to the list of trusted IP addresses:
# plesk bin ip_ban --add-trusted 203.0.113.2
Additional Information
To find out why an IP address got banned by Fail2Ban, see this KB article.
Comments
3 comments
I am having this same issue. Currently getting ERR_CONNECTION_TIMED_OUT but there are no IPs in Fail2ban.
I can connect from my iphone when wireless is off (cellular connection), but not from any device using the wireless network and IP.
MediaTemple confirmed my IP is not on a banned list as well. What to do?
@llull,
Hi! Such an error is often related to the network or firewall. I suggest checking the network configuration on your router and check if there are any firewall rules which can block the connection.
@Artyom Baranov
Thank you, it was a firewall setting, and I'm able to log in now after adjusting the settings. Much appreciated.
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