Applicable to:
- Plesk for Linux
- Plesk for Windows
Symptoms
Cannot create/manage/delete FTP accounts. There is no option FTP Access in Domains > example.com.
Cause
Management of additional FTP accounts is disabled on a Service Plan/Subscription level.
Resolution
-
Go to Service Plans > service_plan_name > Permissions tab > and expand the Show more available permissions.
-
Enable the option Additional FTP accounts management:
-
Click on the Update & Sync button to apply changes for all subscriptions under this service plan.
Note: The changes below will make the subscription a custom one and it will become locked for further synchronization with its Service Plan
-
Go to Subscriptions > example.com.
-
Click on the Customize link under the Account tab:
Note: If the right sidebar is collapsed, expand the right sidebar menu
-
Switch to the Permissions tab and expand the Show more available permissions.
-
Enable the option Additional FTP accounts management:
-
Click OK to apply changes.
To apply the same changes via CLI, use the solution below:
- Connect to the server via SSH.
Execute the command below:
# plesk bin service_plan -u "<service_pan_name>" -manage_subftp true
Note: Replace <service_pan_name> with the required name of the Service Plan
Note: The changes below will make the subscription a custom one and it will become locked for further synchronization with its Service Plan
# plesk bin subscription_settings -u example.com -manage_subftp true
Note: Replace example.com with the real name of the subscription in question
Comments
5 comments
Not very useful the above information, as we migrated a license to Plesk Web Admin license and there is no option to enable FTP account agains.
So the provided "resolution" is really not useful here...
You should provide the following information: plesk bin poweruser --on -simple false -lock false
Which restores all options.
Hello @Michel vd Lingen,
>> You should provide the following information: plesk bin poweruser --on -simple false -lock false
I checked this command in the test environment but it does not restore the Additional FTP Accounts for the subscription.
To allow the owner of the subscription set up additional FTP accounts I used the following command:
# plesk bin subscription_settings -u example.com -manage_subftp true
Thank you for bringing this to our attention!
This article will be updated.
Sorry but you are wrong!
See also this KB: https://support.plesk.com/hc/en-us/articles/115001842594-Some-components-are-missing-from-Plesk-after-downgrading-Plesk-License
So my statement was 100% accurate.
Hello @Michel vd Lingen,
Thank you for the clarification.
Indeed, this wasn't taken into account during the test. Both these articles may be useful but in different cases.
I have added the link to the article which you have mentioned.
This may be helpful to other Pleskians as these articles have a similar symptom.
Thank you Ivan. :)
It might indeed help other users as well, who downgraded their license.
Please sign in to leave a comment.