Atomic ModSecurity ruleset installation fails: Required ruleset configs were not downloaded

Follow

Comments

2 comments

  • Avatar
    Pera Burek

    when I try to run:

    plesk bin server_pref --update-web-app-firewall -waf-rule-engine on -waf-rule-set tortix -waf-rule-set-update-period daily -waf-config-preset tradeoff

    I get errors:
    Unrecognized option: '-waf-rule-set-update-period'

    Unrecognized option: '-waf-config-preset'

    0
    Comment actions Permalink
  • Avatar
    Anzhelika Khapaknysh

    @Pera Burek,

    Most likely it's caused by old Plesk version, cause I've made sure that the options work on both Onyx 17.8 and Obsidian version.

    To check the Plesk version you currently have, run the following command:

    # plesk version

    In case the version is 12.5 and lower, I do highly recommend you upgrading as these versions aren't supported anymore.

    0
    Comment actions Permalink

Please sign in to leave a comment.

Have more questions? Submit a request