Symptoms
- Domain was successfully created in Plesk, but DNS zone was not created in DNS server.
- DNS records were modified for example.com at Domains > example.com > DNS Settings, but DNS zone was not changed in DNS server.
- When debug logging is enabled below error can be found in
C:\Program Files (x86)\Plesk\admin\logs\php_error.log
CONFIG_TEXT: [2018-03-13 16:28:06] DEBUG [util_exec] [5aa7fc169f881] Starting: dnsmng --update --zone-name=example.com --without-reverse, stdin:
[2018-03-13 16:28:06] PHP Fatal error: Uncaught Exception: Unable to execute application: Unable to start ("C:\Program Files (x86)\Plesk\/admin/bin/dnsmng" --update "--zone-name=example.com" --without-reverse)<br> at Plesk impersonation(PipeServer::ServerThread::simpleRunAs line 700)<br> at (zif_plesk_exec line 874) in C:\Program Files (x86)\Plesk\admin\plib\common_func.php:148 - In
C:\Program Files (x86)\Plesk\admin\bin
there areDNSMng.exe
and emptydnsmng
files.
Cause
Empty file dnsmng file is used. This file should not exist in C:\Program Files (x86)\Plesk\admin\bin
.
Resolution
- Login to the server via RDP.
- Remove empty
C:\Program Files (x86)\Plesk\admin\bin\dnsmng
file.
Comments
0 comments
Please sign in to leave a comment.