Applicable to:
- Plesk Onyx for Linux
Symptoms
-
It is not possible to restore a full subscription backup when logged in under a customer account. After selecting a backup and clicking the Restore button, a window with IP address mapping settings appears:
-
when clicking Save Current IP Mapping to File, the following error message appears:
PLESK_WARN: Permission denied
-
when clicking OK, nothing happens.
-
-
Several IP addresses are defined at Tools & Settings > IP Addresses.
- When logged in under Plesk administrator, the same backup restores successfully.
Cause
This is a Plesk bug with ID PPPM-8094, which will be fixed in future product updates.
Resolution
As workaround, perform the following:
-
Connect to a Plesk server via SSH.
-
Create a backup of the original file /usr/local/psa/admin/plib/backup/Conflicts/Detector.php:
# mv /usr/local/psa/admin/plib/backup/Conflicts/Detector.php /usr/local/psa/admin/plib/backup/Conflicts/Detector.php_back
-
Download the patched file, unpack it and put instead of the original file using these commands:
# wget https://support.plesk.com/hc/article_attachments/360009985953/Detector-PP-17.5-2018.08.03.zip
# unzip ./Detector-PP-17.5-2018.08.03.zip
# mv ./Detector.php /usr/local/psa/admin/plib/backup/Conflicts/Detector.php -
Set the correct ownership and permissions for the patched file:
# chown root:root /usr/local/psa/admin/plib/backup/Conflicts/Detector.php
# chmod 644 /usr/local/psa/admin/plib/backup/Conflicts/Detector.php
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