Plesk Onyx for Linux
kb: technical
ABT: Group B
Applicable to:
- Plesk Onyx for Linux
Symptoms
- Slave DNS server is configured with Slave DNS Manager extensions according to the documentation;
- In Plesk > Extensions > Slave DNS Manager Slave DNS server is shown as up and running:
- Signals to refresh zones are received, but zones are not transferred. In
/var/log/messages
; only the following entries appear after clicking Extensions > Slave DNS Manager > Resync:# tail -fn0 /var/log/messages
named[3082]: received control channel command 'refresh example.com IN '
named[3082]: received control channel command 'addzone example.com IN { type slave; file "example.com"; masters { 203.0.113.2; }; };'
Cause
Insufficient default permissions for BIND directory.
Resolution
- Connect to the slave DNS server via SSH;
- Adjust permissions as follows:
# chown named.named /var/named/
Comments
6 comments
rndc works.tested key and port this way.
updateing an existing domain works too.
but a new domain is not added on the slave bind server.
cannot see command "rndc addzone".
Wheres the problem?
Hello @Alexander,
From the issue description I see that the deeper investigation is required.
If the issue is still actual, please, submit a request to us:
https://support.plesk.com/hc/en-us/articles/213608509-How-to-submit-a-request-to-Plesk-support-
I tried to do that. But I´m not allowed to. I got my Plesk license from hetzner.de.
As I know, most of the time, what I do and it worked for more than two years and then suddenly stoped working, I think it is a problem caused by an update. Either os or plesk. i dont think hetzner.de can help a lot.
Plesk support is a bad expirience. At lease till today.
@Alexander Waller,
Being our partner, Hetzner has to provide the initial support to you as you've bought the license there.
In case they won't be able to help you, they'll create a ticket our Support Team to assist. So you may contact Hetzner.
You can also contact Plesk Support directly after purchasing support subscription. The 1st month is free.
We'll be glad to thoroughly check the issue you've mentioned.
Alexander Waller konntest du das lösen. Ich denke ich bin auf das selbe Problem gelaufen und haben nach langer erfolgloser Fehlersuche hier einen Beitrag geöffnet. https://talk.plesk.com/forums/plesk-obsidian-for-linux.748/
Alexander Waller I have found the issue on my servers. Maybee it can also help on your case!
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