Applicable to:
- Plesk for Windows
Symptoms
- Unable to migrate or restore a database from the backup:
PLESK_ERROR: The database was backed up on a server running version 17.00.xx. That version is incompatible with this server, which is running version 12.00.xx. Either restore the database on a server that supports the backup or use a backup that is compatible with this server.
- Default database server for MSSQL in Tools & Settings > Database Servers or in the service plan in Service Plans > plan_name > Hosting Parameters is older then the database version that is being transferred.
Cause
Microsoft SQL database cannot be restored on an SQL server with a lower version.
Resolution
If there is no installed MSSQLSERVER2017 (version that is being migrated) in Tools & Settings > Database Servers:
- Login to Plesk on the target server
- Install Microsoft SQL Server (SQL2017) at Tools & Settings > Updates & Upgrades
- Temporarily choose newly installed MSSQL server as default for MSSQL.
- Re-sync database files in Plesk > Tools & Settings > Migration & Transfer Manager > <migration_session> > Overview > re-sync next to the affected subscription > select Migrate database data (tables, rows, etc).
- Change default server for MSSQL back to initial one.
- Login to Plesk
- Install Microsoft SQL Server (SQL2017) at Tools & Settings > Updates & Upgrades
- Temporarily choose newly installed MSSQL server as default for MSSQL.
- Restore database from the backup
If MSSQLSERVER2017 (version that is being migrated) is already installed in Tools & Settings > Database Servers:
- Login to Plesk on the target server
-
Go to Service Plans > plan_name > Hosting Parameters and set newer MSSQL version as Default Database Server. MSSQL version should be the same or higher then on source server.
Comments
0 comments
Please sign in to leave a comment.