Applicable to:
- Plesk for Linux
- Plesk for Windows
Symptoms
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Backup to remote FTP server fails with the error:
CONFIG_TEXT: Error: server "server"
Curl error: Unable to resume an interrupted upload: (55) Failed sending data to the peer: Last FTP request: APPE backup_1801300838.zip: Last FTP response: 150 Opening BINARY mode data connection for backup_1801300838.zip: Connection to the FTP server has lost
CONFIG_TEXT: Unable to create remote backup. Error: Unable to export backup: Curl error: Unable to resume an interrupted upload: (55) Failed sending data to the peer: Last FTP request: APPE backup_2008150549.tar: Last FTP response: 150 Accepted data connection: Connection to the FTP server has lost
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The following error can be found in the
/var/log/plesk/PMM/backup-YYYY-DD-MM-hh-mm-ss-xxx/backup.log
file:PLESK_INFO: INFO: Unable to resume interrupted upload[1a23b456-1a2b-1234-12a3-a1b2c456d789]: Unable to resume an interrupted upload. It seems like FTP server deleted the file, when the connection was lost. Try to repeat or perform upload manually: The connectivity problem: (55) Failed sending data to the peer: Last FTP request: STOR backup_YYMMDDhhmm.tar: Last FTP response: 150 Opening BINARY mode data connection for backup_YYMMDDhhmm.tar [:0]
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If the option Save backups in the server storage if the upload to FTP fails is enabled at Tools & Settings > Backup Manager > Settings the locally created backup can contain the following multiple warning:
PLESK_INFO: [WARNING]: Cannot dump domain hosting content [Curl error: Unable to resume an interrupted upload: (55) Failed sending data to the peer: Last FTP request: APPE backup_1801300838.zip: Last FTP response: 150 Opening BINARY mode SSL data connection for 'backup_1801300838.zip': Connection to the FTP server has lost]
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The debug log
%plesk_dir%\PMM\logs\backup-YYYY-DD-MM-hh-mm-ss-xxx\backup
contains entries about several unsuccessful attempts to resume the FTP connection and upload files:PLESK_INFO: Debug: Curl error: (55) Failed sending data to the peer: Last FTP request: APPE backup_1801300838.zip: Last FTP response: 150 Opening BINARY mode data connection for backup_1801300838.zip
Debug: Pause before next attempt to upload file...
Debug: Trying to resume upload...
Cause
The FTP server or FTP user exceeded quotas or limits, e.g hard disk quota, in the middle of the backup process.
Resolution
Check and adjust the limits and quotas for the FTP server and user.
Note: if this limit is a FTP timeout, it is possible to avoid this issue by enabling multivolume backup in Tools & Settings > Backup Manager > Schedule > Create a multivolume backup, volume size (MB).
Comments
6 comments
Can't see "Create a multivolume backup" in Version 18.0.30 Update #3
We have the same problem, and a multivolume backup did not resolve it.
Plesk uses only one FTP connection to upload all files, it doesnt matter if its only 1 file or 10 with multivolume backup enabled.
In our case, a full backup is nearly 200GB of Data and it runs in timeouts, cause plesk want only use 1 connection and not tries to reestablish the connection if multivolume backup is enabled.
A few parts of the Backup finished, but even so, plesk deletes them if a single error occours and not tries it again.
There are two options. We can increase our ftp server connection timeout limits to 12 hours and more. Or plesk will fix this issue on theire side. Plesk have just to implement a reconnect function or to do a reconnect after each part of the multivolume backup.
edit: It looks like this problem exists since 2016, cause there was a poll started to implement the resume feature:
https://plesk.uservoice.com/forums/184549-feature-suggestions/suggestions/14739267-resume-ftp-backup-upload-on-fail#%7Btoggle_previous_statuses%7D
Hi,
i tried to change volume size to 2000Mb but it wont help, even smaller size does same error. This problem was not before i installed plesk again to new server. It would be nice to get ftp backup workin. Seem to have something else wrong now.
Another thing what im wondering, is that there is told to adjust limits and quotas, so are those limiting administrator / system scheduled backups too (not any sense if are).
Thanks-
Hello @Marko Puskala
In this case, I can suggest submitting a request to our Technical Support: https://support.plesk.com/hc/en-us/articles/213608509-How-to-submit-a-request-to-Plesk-support-
We have identified the same issue. What appears to be happening is that Plesk opens the SFTP connection on the target server BEFORE the backup is started. Then Plesk starts the backup process. Once the backup is completed, then Plesk tries to use that same connection to write the files to the target server. However, by this time the SFTP connection has timed out and the connection is closed. The default idle timeout for ProFTPD for example is 10 minutes. I've raised a support request with Plesk #315762 to try and get this feature changed so that the backup is created FIRST and only then is the SFTP connection opened and the backup file written.
Same problem here with 4 different servers. Manual copies worked fine, so it is not a problem of size, space... I think is a plesk problem...
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