Applicable to:
- Plesk for Linux
- Plesk for Windows
Symptoms
- In Subscriptions > example.com > Email address tab > johndoe@example.com (user column) leads to the User tab showing the error:
PLESK_ERROR: Access denied.
- OwnerId in the smb_users table does not match. To verify this find out user ID in the Subscriprions > example.com > Account in the right side - put mouse on a customer and below his id is shown:
-
Check ID of smb_user mentioned in the e-mail address:
-
accountId
(e-mail user) andownerId
(customer/reseller) do not match to IDs from step 2 and 3 above:MYSQL_LIN: mysql> SELECT ownerId from smb_users where id="5";
+---------+
| ownerId |
+---------+
| 7 |
+---------+
1 row in set (0.00 sec)
Cause
Database inconsistency. Incorrect ownerId in smb_users
table.
Resolution
-
Connect to the server via SSH
-
Backup Plesk database.
-
Access Plesk database with the command:
# plesk db
-
Update the ownerId field:
MYSQL_LIN: mysql> update smb_users set ownerId=2 where id=5;
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