Symptoms
After a domain created with Sitejet Builder is migrated, opening the Sitejet Builder editor on the target (new) Plesk server fails:
Error: Can not access Sitejet Website Builder for this domain. Please check if this domain has been migrated or restored onto another server.
Cause
After the migration, API key required for the Sitejet Builder to be accessible was not regenerated.
Resolution
Contact Plesk Technical support with granting server access and providing the Plesk license installed on the target server.
After getting the above info, proceed in accordance with instructions from R&D (were provided in Slack):
-
Make sure that the Sitejet Builder extension is up-to-date (1.2.0 or newer).
- Check
panel.log
/php_error.log
and Tools & Settings > Task Manager to check if all went well during the upgrade.
- Check
-
In case the extension is up-to-date and you see an error like Error: Can not access Sitejet Website Builder for this domain. Please check if this domain has been migrated or restored onto another server, do the following:
- Create a psa DB backup.
- Execute query
delete from ModuleSettings where name = 'plesk_editor_api_key';
- Try accessing Sitejet Builder again on any domain, it should trigger API key re-generation.
-
In case the error still persists, it is of utmost importance to understand what license keys are installed on this Plesk and what were installed on the server in the past. What does it mean:
- Grab all the license key files from the server, e.g. for Linux, grab all the files from
/etc/sw/keys/keys/
and attach them to the request in #sitejet-support Slack channel. - R&D team will ask if any additional information is required.
- Grab all the license key files from the server, e.g. for Linux, grab all the files from
Comments
1 comment
As far as I know, the domain has not been migrated from another server.
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