Applicable to:
- Plesk for Linux
Symptoms
-
On a Plesk server (commonly running on Ubuntu or another Debian-based operating system), the Imunify extension shows the alert Stopped once you open it by going to Plesk > Imunify. Pressing the Retry button displays an empty log window and returns only the following:
PLESK_ERROR: Error
undefined -
The same process may get stuck with a different message after reinstalling the extension
In a few moments the script will install latest imunify-antivirus package (w/dependencies)... (Ctrl-C to cancel)
- The following errors shows up in Plesk in relation to a failed Plesk update attempt:
CONFIG_TEXT: E: The package imunify-common needs to be reinstalled, but I can't find an archive for it.
Cause
Inconsistencies in the system packages and a lack of available source for the reinstallation of the imunify-common
package.
Resolution
-
Log into your server via SSH
-
Manually install Imunify with their installation script by executing one of the following commands:
For ImunifyAV and ImunifyAV+ licenses:
# wget https://repo.imunify360.cloudlinux.com/defence360/imav-deploy.sh && bash imav-deploy.sh
For Imunify360 licenses:
# wget https://repo.imunify360.cloudlinux.com/defence360/i360deploy.sh && bash i360deploy.sh
Warning: If this fails with en error about
alt-python311-libs
andgnupg
, install the latter manually and rerun the installation script by executing the following command:# apt update && apt install -y gnupg && bash imav-deploy.sh || bash i360deploy.sh
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