kb: bug
Plesk for Linux
Symptoms
1. Plesk update 61 has been recently installed on Plesk server with previously enabled HTTP/2
2. Command # nginx -t
or cron tasks show error:
PLESK_ERROR: New configuration files for the Apache web server were not created due to the errors in configuration templates: nginx: [warn] the "listen ... http2" directive is deprecated, use the "http2" directive instead in /etc/nginx/plesk.conf.d/webmails/example.com_webmail.conf
Cause
Nginx directives for HTTP2 were updated by package vendor. Web server configuration was not regenerated during the update installation to avoid unplanned websites downtime.
Resolution
- Applying the solution on a server with thousands domains can increase temporary sites downtime. In that case, apply the solution during server maintenance hours.
- Log in to Plesk via SSH
- Trigger nginx configuration files regeneration:
# plesk bin http2_pref --disable
# plesk bin http2_pref --enable
Comments
9 comments
eta for PPPM-14442?
Michael, I have updated the cause.
# plesk bin http2_pref --disable && plesk bin http2_pref --enable
Hi,
whenever you perform this I think it causes a downtime of websites or, because if you have for instance 9k NGINX config files it is adding / removing the symlink (-> /etc/nginx/plesk.conf.d/vhosts/*.conf) the process is taking longer and if there is an NGINX reload during this process customer websites are offline or is this something which has been already fixed (we had this problem around 2k21!)
thx for clarification
cheers Michael
Michael
PPPM-14442 was not recognized as bug due to low business impact (sites are up after update) that does not worth automatic reconfiguration of all domains (that temporarily brings the sites down). I will update the article with a warning that reconfiguration of thousands of sites will cause increased temporary downtime.
thx for adding the warning and clarificaiton, cheers Michael
As it is not the best option for every business, is it planned to solve it before it is becoming a "real" problem (upcoming versions?), because the deprecation warning is not the problem at least for me
cheers Michael
@Michael This question requires investigation. Please create a ticket to Plesk technical support.
>> @Michael This question requires investigation. Please create a ticket to Plesk technical support.
Your insights are always spot on. Love your blog! URL
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