Applicable to:
- Plesk for Linux
Symptoms
- Incoming emails are delayed often
- Errors that are similar to the following appear in the
/var/log/maillog
of the server:
CONFIG_TEXT: Nov 6 02:57:42 el7p17 postfix/smtpd[18663]: 1934840B4BF3: milter-reject: DATA from localhost.localdomain[127.0.0.1]: 451 4.7.1 Service unavailable - try again later; from=<sender@example.com> to=<test@example.com> proto=SMTP helo=<localhost.localdomain> Nov 6 02:57:44 el7p17 postfix/smtpd[18663]: A914C40B4BF3: milter-reject: DATA from localhost.localdomain[127.0.0.1]: 451 4.7.1 Service unavailable - try again later; from=<sender@example.com> to=<test@example.com> proto=SMTP helo=<localhost.localdomain>
- The Switch on server-wide greylisting spam protection option is enabled in Plesk > Tools & Settings > Mail > Spam Filter
Cause
Such behavior is expected when you have Switch on server-wide greylisting spam protection enabled in Plesk > Tools & Settings > Mail > Spam Filter
Greylisting protects your domain from spam by declining the first connection attempt from unknown senders, and then accepting a later connection as an additional security measure.
Resolution
No action is required, because such behavior is expected whenever Greylisting is enabled on a Linux Plesk server.
If these expected delays are causing issues for you, you may disable greylisting by following these steps:
1. Log into Plesk
2. Go to Tools & Settings > Mail > Spam Filter
3. Uncheck the box for Switch on server-wide greylisting spam protection
4. press Apply
Additional information
Greylisting (Linux) | Plesk Obsidian documentation
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