Migration fails on Plesk 12.5: decryptBackup() takes exactly 2 arguments (3 given)

Created:

2016-12-12 03:48:52 UTC

Modified:

2017-08-08 13:21:37 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Migration fails on Plesk 12.5: decryptBackup() takes exactly 2 arguments (3 given)

Applicable to:

  • Plesk 12.5 for Linux

Symptoms

Migration fails with the error:

decryptBackup() takes exactly 2 arguments (3 given)

Cause

Plesk Migration Manager is used. In Plesk 12.5, it is replaced with Plesk Migrator.

Resolution

Install Plesk Migrator:

Via Plesk interface :

  1. Log in as administrator to Plesk on the target server.
  2. Go to Tools & Settings > Updates & Upgrades > Add/Remove Components .
  3. Select Install next to the Plesk Migrator component.

Via command line :

  1. Log in to the target server via SSH as the root user.
  2. Run the Plesk Installer as follows:

    # plesk installer
  3. Go through the installation wizard following the on-screen instructions until the component selection stage is reached.

  4. Mark the Plesk Migrator component for installation and complete the procedure following the on-screen instructions.

To read more about new Plesk Migrator check Migration Guide .

Have more questions? Submit a request
Please sign in to leave a comment.