Domain's DNS zone does not transferred to slave DNS servers if servers behind NAT

Created:

2016-12-12 03:48:28 UTC

Modified:

2017-08-08 13:39:52 UTC

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Domain's DNS zone does not transferred to slave DNS servers if servers behind NAT

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk Onyx for Windows

Symptoms

  1. After upgrade from Plesk 12.o to 12.5 DNS zones for newly created domains cannot be syncronized. As a result new domains cannot be resolved.

  2. Plesk 12.5 server is behind NAT and public IP(10.20.30.40) is set for local IP in Home > Tools&Settings > IP Addresses , and Slave DNS Manager is used (slaves DNSs also behind NAT).

  3. Slave server fails to connect to master with the following error in /var/log/syslog file on the name server:

    Sep 10 13:54:58 hostname named[951]: received control channel command 'addzone example.com { type slave; file "example.com"; masters { 10.20.30.40; }; };'
    Sep 10 13:58:35 hostname named[951]: transfer of 'example.com/IN' from 10.20.30.40#53: failed to connect: timed out
    Sep 10 13:58:35 hostname named[951]: transfer of 'example.com/IN' from 10.20.30.40#53: Transfer completed: 0 messages, 0 records, 0 bytes, 127.332 secs (0 bytes/sec)

Cause

Slave DNS Manager extension for Plesk 12.5 uses only public IP addresses.

Workaround

  1. Make sure that slave nameservers can access Plesk on public IP address via port 53.

  2. If step above do not help, reinstall Slave DNS Manager extension and set it up to use public IP addresses.

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