Plesk Onyx Update#5

Created:

2016-12-12 03:47:31 UTC

Modified:

2017-05-16 12:12:32 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Plesk Onyx Update#5

Applicable to:

  • Plesk Onyx for Linux
  • Plesk Onyx for Windows

Release Notes

Plesk team is pleased to introduce the new Update #5 for the Plesk Onyx.

The Plesk Onyx Update #5 is recommended for all Plesk users and includes general functionality fixes that improve the stability, compatibility, and security of your Plesk server.

To ensure optimal server reliability and security, we strongly recommend keeping your operating system and Plesk software up-to-date.

What's Changed

Plesk Onyx MU#5

[+] (on Linux) Virtuozzo 7 is now supported, starting from Update 1 Hotfix 1 (7.0.1-686).

For details, refer to: https://help.virtuozzo.com/customer/portal/articles/2622351.

Note: Virtuozzo increased security for CentOS 7 containers with this update. Now containers are created with firewall enabled by default.

Plesk administrator needs to open ports that are necessary for Plesk: https://kb.plesk.com/en/391.The Resource Controller feature is now available on Virtuozzo 7.

New Virtuozzo Application templates were created to support this functionality.

[+] (on Linux) The Resource Controller feature is now available on Virtuozzo 7. New Virtuozzo Application templates were created to support this functionality.

[+] (on Linux) Virtuozzo Linux 7 is now supported on Virtuozzo 7. Plesk can be installed on Virtuozzo Linux container using Virtuozzo templates. Refer to https://virtuozzo.com/products/virtuozzo-linux/.

[*] Plesk administrator’s PHP version was updated to 5.6.27.

[*] Execution of system operations in Plesk user interface became faster.

The following issues were resolved:

[-] Saving Plesk backup to FTP storage failed with a confusing error message in the backup log. (PPP-26576)

[-] Customer could not restore several selected objects after server backup. (PPP-26564)Plesk user interface view could not be changed via CLI.(PPP-26550)

[-] It was impossible to use an FTP server with extended passive mode disabled as FTP storage for a backup. (PPP-26546)

[-] A DNS record of PTR type could not be added in DNS settings of a subscription for an IPv6 address with a 3-digit netmask. (PPPM-5063)

[-] When a suspended customer was removed and then restored from a backup, the status of the domain mail service on this customer’s subscription was not restored. (PPP-26450)

[-] (on Linux) Unnecessary warning messages were displayed when Plesk was installed with the Phusion Passenger server component.(PPP-26597)

[-] (on Linux) Garbage directories were present in the DUMP_D directory after restoring a subscription from a backup stored on FTP. (PPP-26517)

[-] (on Linux) After installing Plesk, the automatic updates for third-party components shipped by Plesk were disabled. (PPP-26511)

[-] (on Linux) SpamAssassin failed to start if Plesk was installed on CentOS with IPv6 support turned off. (PPP-26509)

[-] (on Linux) Removing the Phusion Passenger server component did not disable Phusion Passenger in Apache, and the server configuration was broken. (PPP-26453)

[-] (on Windows) Duplicated Node.js items were present in the components list of Plesk installer for Windows. (PPP-26387)

[-] (on Windows) Server backup failed if an application was installed from the APS catalog but the APS package archive was absent in the file system.(PPPM-5030)

Extension Updates

Multi Server 1.0.0[+] Automatic and manual distribution of subscriptions between connected service nodes.

[+] All Plesk users, including administrators, can log into to all connected servers from a single place.

[+] Centralized account management across multiple Plesk instances.

[+] Centralized management of tools and settings across multiple Plesk instances.

[+] API for billing / external system integration

[+] WHMCS billing support out of the box

Docker 1.3.0

[+] Docker is supported on Virtuozzo 7 and separate Virtuozzo Application templates are now available for Plesk Docker.

WordPress Toolkit 1.2.0

[-] If an extension version was changed from 2-digit to 3-digit, the extension upgrades were unavailable. (PPP-26678)

Legend:

[+] - Added

[-] - Fixed

[*] - Improved

Installation Instructions

#128626 : Using Micro-Updates in Plesk

A complete list of changes can be found here:

Plesk Onyx Change Log

Have more questions? Submit a request
Please sign in to leave a comment.