Applicable to:
- Plesk Onyx for Linux
Symptoms
-
Unable to start migration:
CONFIG_TEXT: Failed to connect to target Plesk server by Plesk API: Plesk error [1006]: Access to API is disabled for 203.0.113.2
-
Cannot access Plesk on the target server via HTTPS. Error in Google Chrome:
CONFIG_TEXT: ERR_CONNECTION_TIMED_OUT
Cause
8443 TCP port is closed on the target server.
Resolution
-
Allow connection to 8443 TCP port on the target server:
- Connect to the server via SSH ;
- Run the following command to open port in
iptables
:
# iptables -I INPUT 1 -p tcp --dport 8443 -j ACCEPT
-
Make sure that connection is possible from the target server on 8443 port locally and remotely. For example:
# telnet example.com 8443
Trying 203.0.113.3...
Connected to 203.0.113.3.
Escape character is '^]'.
Note: If the above instructions did not help and the port is still inaccessible, it means it is blocked on a higher level. Contact your service provider to find what blocks the access.
Additional information
#213916665 Migration to Plesk 12.5 fails: Access to API is disabled
Comments
1 comment
This error is also received if you've blocked access to the API using the following in the panel.ini:
Or if you have admin logins restricted by IP.
It *also* provides this error when using the migration manager if the local server IP hasn't been allowed in both of those places.
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