Unable to install Plesk: error processing package libapache2-mod-php5

Created:

2016-12-12 03:44:08 UTC

Modified:

2017-08-08 13:41:33 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Unable to install Plesk: error processing package libapache2-mod-php5

Applicable to:

  • Plesk Onyx for Linux

Symptoms

Unable to complete installation of Plesk due to the following error:

ERROR: Config file dir.conf not properly enabled: /etc/apache2/mods-enabled/dir.conf is a real file, not touching it
dpkg: error processing package apache2 (--configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of libapache2-mod-php5:
libapache2-mod-php5 depends on apache2 (>= 2.4); however:
Package apache2 is not configured yet.

dpkg: error processing package libapache2-mod-php5 (--configure):
dependency problems - leaving unconfigured

Cause

Plesk installation was interrupted earlier and apache2 package has already been installed.

Resolution

  1. Remove apache2 package with all its dependencies:

    # yum remove apache2
  2. Remove the /etc/apache2 directory:

    # rm -rf /etc/apache2
Have more questions? Submit a request
Please sign in to leave a comment.