Unable to install Wordpress: Can't open lib /usr/lib64/odbc/libmyodbc5w-plesk.so

Created:

2016-12-12 03:42:41 UTC

Modified:

2017-08-08 13:24:38 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Unable to install Wordpress: Can't open lib /usr/lib64/odbc/libmyodbc5w-plesk.so

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 12.0 for Linux

Symptoms

  • An installation of Wordpress fails with the following error:

    ODBC error #01000: [unixODBC][Driver Manager]Can't open lib '/usr/lib64/odbc/libmyodbc5w-plesk.so' : file not found
  • File libmyodbc5w-plesk.so does not exist:

    # ls -la /usr/lib64/odbc/libmyodbc5w-plesk.so
    ls: cannot access /usr/lib64/odbc/libmyodbc5w-plesk.so: No such file or directory
  • File libmyodbc5.so exists:

    #ls -la /usr/lib64/libmyodbc5.so
    lrwxrwxrwx 1 root root 14 Oct 19 14:46 /usr/lib64/libmyodbc5.so -> libmyodbc5w.so

Cause

Incorrect paths for MySQL drivers.

Resolution

  1. Create a backup of /etc/odbcinst.ini :

    # cp -p /etc/odbcinst.ini{,.bak}
  2. Edit /etc/odbcinst.ini with a text editor.

  3. In [MySQL] section change Driver and Driver64 paths to /usr/lib64/libmyodbc5.so

Have more questions? Submit a request
Please sign in to leave a comment.