Unable to add slave node: Currently selected web statistics package does not support secure access through the /plesk-stat/ protected directory

Created:

2016-12-12 03:42:25 UTC

Modified:

2017-08-08 13:32:23 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Unable to add slave node: Currently selected web statistics package does not support secure access through the /plesk-stat/ protected directory

Applicable to:

  • Plesk Onyx for Linux

Symptoms

Unable to add slave node in Plesk Multi Server extension:

ERR Currently selected web statistics package does not support secure access through the /plesk-stat/ protected directory

At the same time the following error appears in /var/log/plesk/panel.log :

ERR [extension/plesk-multi-server] Task run failed with message 'Currently selected web statistics package does not support secure access through the /plesk-stat/ protected directory'

Cause

No default value for webstatistics is specified in psa.TmplData table for default service plan template on Management Node.

Resolution

  1. Create backup of psa database on Management Node:

    # plesk db dump psa > /root/psq_dump.sql
  2. Update psa.TmplData table with correct value on Management Node:

    mysql> update TmplData set value='webalizer' where element='webstat' and tmpl_id=1;
    Query OK, 1 row affected (0.00 sec)
    Rows matched: 1 Changed: 1 Warnings: 0
  3. Add slave node again.

Have more questions? Submit a request
Please sign in to leave a comment.