Debian postupgrade script fails: Bootstrapper repair actions failed

Created:

2016-12-12 03:41:27 UTC

Modified:

2017-08-08 13:31:34 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Debian postupgrade script fails: Bootstrapper repair actions failed

Applicable to:

  • Plesk 12.5 for Linux

Symptoms

Postupgrade script /opt/psa/bin/distupgrade.helper.deb6-deb7_post.x64.sh fails with error:

    + TRANSACTION_STARTED=
+ TRANSACTION_ROLLBACK_FUNCS=
+ TRANSACTION_COMMIT_FUNCS=
+ trap - HUP PIPE INT QUIT TERM EXIT
+ exit 1
Bootstrapper repair actions failed
Some error during dist-upgrade post stage occurs.
Check /var/log/plesk/install/plesk-distupgrade.log for error details.
Visit http://docs.plesk.com/en-US/current/administrator-guide/server-administration/distupgrade-support/ for information about
troubleshooting and recovering dist-upgrade.

There is an error in the /var/log/plesk/install/plesk-distupgrade.log file:

    Syntax error on line 34 of /etc/apache2/plesk.conf.d/horde.conf: Wrapper /var/www/cgi-bin/cgi_wrapper/cgi_wrapper cannot be accessed: (2)No such file or directory

Cause

The file /var/www/cgi-bin/cgi_wrapper/cgi_wrapper does not exist on the server.

Resolution

Reinstall psa-php5-configurator package.

In example below, psa-php5-configurator the package for Plesk 12.5 x64 for Debian 7 is reinstalled:

  1. Download psa-php5-configurator package:

    # wget http://autoinstall.plesk.com/PSA_12.5.30/dist-deb-Debian-7.0-x86_64/opt/php5/psa-php5-configurator_1.7.0-debian7.0.build1205150819.14_amd64.deb
  2. Reinstall it with the command below:

    # dpkg -i psa-php5-configurator_1.7.0-debian7.0.build1205150819.14_amd64.deb
Have more questions? Submit a request
Please sign in to leave a comment.