Customer control panel is inaccessible: Access to the location account/switch is denied.

Created:

2016-12-12 03:48:41 UTC

Modified:

2017-08-16 18:27:17 UTC

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Customer control panel is inaccessible: Access to the location account/switch is denied.

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk Onyx for Windows
  • Plesk 11.x for Linux
  • Plesk 12.0 for Linux

Symptoms

Unable to access domain example.com in Plesk interface:

Error: Access to the location account/switch is denied

or

Error: Access to the location web/view is denied

Check and Repair in Plesk Reconfigurator shows errors:

Unable to execute "D:\\Program Files (x86)\\Parallels\\Plesk\\admin\\bin\\mailmng.exe" --reconfigure-dns-servers:
Access is denied. (Error code 5) at Unable to connect to pipe \\\\.\\pipe\\P_fb471d0a-8f57-423b-a958-9da7f589f365
at (Con::ClientOverlappedPipe::create line 503)
at get shared instance of PleskSrvClient(PleskSrvClient::getInstance line 344)
at Load mail provider(mailmng::imailmngprovider::load line 456)
at execute console command --reconfigure-dns-servers(vconsoleapp::start line 122)
at execute "D:\\Program Files (x86)\\Parallels\\Plesk\\admin\\bin\\mailmng.exe" --reconfigure-dns-servers(vconsoleapp::run line 139)
Access is denied
Access is denied

Cause

Database inconsistency: lack of permissions to the owner of subscription.

Resolution

  1. Find the domain's owner ID:

    mysql> select name, cl_id from domains where name='example.com';
    +---------------+-------+
    | name | cl_id |
    +---------------+-------+
    | example.com | 3 |
    +---------------+-------+
    1 row in set (0.00 sec)
  2. Find the domain's owner login name:

    mysql> select id,login from clients where id=3;
    +----+-----------+
    | id | login |
    +----+-----------+
    | 3 | owner |
    +----+-----------+
    1 row in set (0.00 sec)
  3. Find the roleID for this user:

    mysql> select login, roleID from smb_users where login='owner';
    +-----------+--------+
    | login | roleID |
    +-----------+--------+
    | owner | 9 |
    +-----------+--------+
    1 row in set (0.00 sec)
  4. Check permissions granted to the user:

    mysql> select * from smb_roleGeneralPermissions where roleID=9;
    Empty set (0.00 sec)

The description of those permissions can be found in smb_generalPermissions table:

    mysql> select * from smb_generalPermissions;
+----+------------------------------+

| id | code |
+----+------------------------------+
| 1 | userManagement |
| 2 | webSitesAndDomainsManagement |
| 3 | logRotationManagement |
| 4 | anonymousFtpManagement |
| 5 | scheduledTasksManagement |
| 6 | spamfilterManagement |
| 7 | antivirusManagement |
| 8 | databasesManagement |
| 9 | backupRestoreManagement |
| 10 | browseStats |
| 11 | applicationsManagement |
| 12 | sitebuilderManagement |
| 13 | filesManagement |
| 14 | ftpAccountsManagement |
| 15 | dnsManagement |
| 16 | javaApplicationsManagement |
| 17 | mailManagement |
| 18 | mailListsManagement |
+----+------------------------------+
18 rows in set (0.00 sec)
  1. Create a backup of the database according to instructions from article #213904125

  2. Grant all permissions to the user:

    mysql> update smb_roleGeneralPermissions set isAllowed=1 where roleId=9;

After that smb_roleGeneralPermissions table will look like:

    mysql> select * from smb_roleGeneralPermissions where roleID=9;
+-----+--------+---------------------+-----------+
| id | roleId | generalPermissionId | isAllowed |
+-----+--------+---------------------+-----------+
| 349 | 9 | 1 | 1 |
| 350 | 9 | 2 | 1 |
| 351 | 9 | 3 | 1 |
| 352 | 9 | 4 | 1 |
| 353 | 9 | 5 | 1 |
| 354 | 9 | 6 | 1 |
| 355 | 9 | 7 | 1 |
| 356 | 9 | 8 | 1 |
| 357 | 9 | 9 | 1 |
| 358 | 9 | 10 | 1 |
| 359 | 9 | 11 | 1 |
| 360 | 9 | 12 | 1 |
| 361 | 9 | 13 | 1 |
| 362 | 9 | 14 | 1 |
| 363 | 9 | 15 | 1 |
| 364 | 9 | 16 | 1 |
| 365 | 9 | 17 | 1 |
| 366 | 9 | 18 | 1 |
+-----+--------+---------------------+-----------+
18 rows in set (0.00 sec)
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