Additional license is not automatically updated

Created:

2016-12-12 03:47:07 UTC

Modified:

2017-08-08 13:21:07 UTC

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Additional license is not automatically updated

Applicable to:

  • Plesk 12.5 for Linux

Symptoms

  1. Dr.Web or other additional license is not automatically updated. There is still old update date shown in:

Tools and Settings > License Management > Additional Key

  1. But it is possible to update the license successfully by clicking on Retrieve button

  2. Running Daily Maintenance Task manually does not update the license:

    # /usr/local/psa/bin/sw-engine-pleskrun /usr/local/psa/admin/plib/DailyMaintainance/script.php -f UpdateKeys
  3. On Key Administrator side (licensing server) Dr.Web license has different Plesk license set as "main license" or "parent key"

  4. Plesk "forgets" the Kaspersky key with 100 mailboxes and falls back to the Kaspersky key with 5 mailboxes).

Cause

Additional license is not associated with Plesk license on Plesk Key Administrator server.

Resolution

  1. Assign Dr.Web license to correct Plesk license that is used on a Plesk server in:

Tools and Settings > License Management

  1. Retrieve both Plesk and Dr.Web licenses in License Management menu.

Additional details

For assistance with re-assigning Dr.Web or other additional license to a different Plesk license, contact Licensing support.

If Additional License is assigned to a correct main Plesk key and issue still persists, visit:

115000067885 Premium Anti virus license is not automatically updated in Plesk but manual retrieval works fine

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