Unable to create a backup of PostgreSQL database in Plesk Onyx: pg_dump: aborting because of server version mismatch

Created:

2016-12-12 03:46:43 UTC

Modified:

2017-08-08 13:21:04 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Unable to create a backup of PostgreSQL database in Plesk Onyx: pg_dump: aborting because of server version mismatch

Applicable to:

  • Plesk Onyx for Linux

Symptoms

Unable to create a backup of PostgreSQL database if database server version is 9.5.

Backup log shows the following error:

WARNING:      (postgresql object 'admin_db')      Failed to execute backup database
WARNING: (postgresql object 'admin_db') Not all the data was backed up into /var/lib/psa/dumps/domains/example.com/databases/admin_db_4 successfully. pg_dump: server version: 9.5.4; pg_dump version: 9.2.15
pg_dump: aborting because of server version mismatch

Cause

This is Plesk bug with ID #PPPM-5078 that is planned to be fixed in future Plesk updates.

Workarounds

The following options are available:

  1. export database dumps via phpPgAdmin

  2. configure Plesk for the newer version of PostgreSQL in /etc/psa/psa.conf , as follows:

    # PostgreSQL
    PGSQL_DATA_D /var/lib/pgsql/9.5/data
    PGSQL_CONF_D /var/lib/pgsql/9.5/data
    PGSQL_BIN_D /usr/pgsql-9.5/bin
Have more questions? Submit a request
Please sign in to leave a comment.